代码拉取完成,页面将自动刷新
同步操作将从 src-openEuler/qpid-proton 强制同步,此操作会覆盖自 Fork 仓库以来所做的任何修改,且无法恢复!!!
确定后同步将在后台操作,完成时将刷新页面,请耐心等待。
%{?filter_setup:
%filter_provides_in %{_datadir}/proton/examples/
%filter_requires_in %{_datadir}/proton/examples/
%filter_setup
}
%global proton_licensedir %{_licensedir}/proton
%{!?_licensedir:
%global license %doc
%global proton_licensedir %{_datadir}/proton}
Name: qpid-proton
Version: 0.39.0
Release: 1
Summary: A high performance and lightweight library for messaging applications
License: Apache-2.0
URL: http://qpid.apache.org/proton/
Source0: https://github.com/apache/qpid-proton/archive/%{version}.tar.gz
Patch0000: proton.patch
BuildRequires: gcc gcc-c++ cmake swig pkgconfig doxygen libuuid-devel openssl-devel
BuildRequires: python3-devel python3-sphinx glibc-headers cyrus-sasl-devel jsoncpp-devel
BuildRequires: python3-cffi
%description
Proton is a high performance, lightweight messaging library. It can be used in
the widest range of messaging applications including brokers, client libraries,
routers, bridges, proxies, and more. Proton makes it trivial to integrate with
the AMQP 1.0 ecosystem from any platform, environment, or language.
%package c-cpp
Summary: C/C++ libs for qpid-proton
Requires: cyrus-sasl-lib jsoncpp
Provides: qpid-proton-c = %{version}-%{release} qpid-proton-cpp = %{version}-%{release}
Obsoletes: qpid-proton perl-qpid-proton qpid-proton-c < %{version}-%{release}
Obsoletes: qpid-proton-cpp < %{version}-%{release}
%description c-cpp
This package contains C/C++ libraries for qpid-proton.
%package c-cpp-devel
Summary: Development C/C++ libs for qpid-proton
Requires: qpid-proton-c-cpp = %{version}-%{release}
Provides: qpid-proton-c-devel = %{version}-%{release} qpid-proton-cpp-devel = %{version}-%{release}
Obsoletes: qpid-proton-devel qpid-proton-c-devel < %{version}-%{release}
Obsoletes: qpid-proton-cpp-devel < %{version}-%{release}
%description c-cpp-devel
This package contains C/C++ development libraries for writing messaging apps with qpid-proton.
%package c-help
Summary: Documentation for the C development libs
BuildArch: noarch
Provides: c-docs = %{version}-%{release}
Obsoletes: qpid-proton-c-devel-doc qpid-proton-c-devel-docs c-docs < %{version}-%{release}
%description c-help
This package contains documentation for the C development libraries and examples for qpid-proton.
%package cpp-help
Summary: Documentation for the C++ development libs
BuildArch: noarch
Provides: cpp-docs = %{version}-%{release}
Obsoletes: qpid-proton-cpp-devel-doc qpid-proton-cpp-devel-docs cpp-docs < %{version}-%{release}
%description cpp-help
This package contains documentation for the C++ development libraries and examples for qpid-proton.
%package -n python3-qpid-proton
Summary: Python language bindings for the qpid-proton
%python_provide python3-qpid-proton
Requires: qpid-proton-c = %{version}-%{release} python3
%description -n python3-qpid-proton
This package contains python language bindings for the qpid-proton messaging framework.
%package -n python-qpid-proton-help
Summary: Documentation for the Python language bindings for qpid-proton
BuildArch: noarch
Provides: python-qpid-proton-docs = %{version}-%{release}
Obsoletes: python-qpid-proton-doc python-qpid-proton-docs < %{version}-%{release}
%description -n python-qpid-proton-help
This package contains documentation for the Python language bindings for qpid-proton.
%package tests
Summary: Tests for qpid-proton
BuildArch: noarch
%description tests
This package contains some tests for qpid-proton.
%prep
%autosetup -n %{name}-%{version} -p1
%build
rm -rf buildpython3 && mkdir buildpython3
pushd buildpython3
python_includes=$(ls -d /usr/include/python3*)
%cmake \
-DSYSINSTALL_BINDINGS=ON \
-DCMAKE_SKIP_RPATH:BOOL=OFF \
-DENABLE_FUZZ_TESTING=NO \
"-DCMAKE_C_FLAGS=$CMAKE_C_FLAGS $CFLAGS -Wno-error=format-security" \
"-DCMAKE_CXX_FLAGS=$CMAKE_CXX_FLAGS $CXXFLAGS -Wno-error=format-security" \
..
make all docs -j1
(pushd python; %py3_build)
%install
pushd buildpython3
%make_install
(pushd python; %py3_install)
find %{buildroot}%{_datadir}/proton/examples/python -name "*.py" -exec sed -i 's/!\/usr\/bin\/env python/!\/usr\/bin\/python3/' {} \;
echo '#!/usr/bin/python3' > %{buildroot}%{_datadir}/proton/examples/python/proton_server.py.original
cat %{buildroot}%{_datadir}/proton/examples/python/proton_server.py >> %{buildroot}%{_datadir}/proton/examples/python/proton_server.py.original
mv %{buildroot}%{_datadir}/proton/examples/python/proton_server.py.original %{buildroot}%{_datadir}/proton/examples/python/proton_server.py
rm -fr %{buildroot}%{_datadir}/proton/examples/**/*.cmake
rm -f %{buildroot}%{_datadir}/proton/CMakeLists.txt
rm -fr %{buildroot}%{_datadir}/proton/examples/go
for fpath in %{buildroot}%{_libdir} %{buildroot}%{_datarootdir} \
%{buildroot}%{_datadir}/proton/examples
do
rm -rf ${fpath}/ruby
done
%post
/sbin/ldconfig
%postun
/sbin/ldconfig
%files c-cpp
%dir %{_datadir}/proton
%license %{_datadir}/proton/LICENSE.txt
%doc %{_datadir}/proton/README*
%{_libdir}/libqpid-proton*
%files c-cpp-devel
%{_includedir}/proton
%{_libdir}/cmake/Proton
%{_libdir}/pkgconfig/*
%{_libdir}/cmake/ProtonCpp
%files c-help
%defattr(-,root,root,-)
%license %{_datadir}/proton/LICENSE.txt
%doc %{_datadir}/proton/examples/README.md
%doc %{_datadir}/proton/docs/api-c
%doc %{_datadir}/proton/examples/c/*
%files cpp-help
%defattr(-,root,root,-)
%license %{_datadir}/proton/LICENSE.txt
%{_datadir}/proton/docs/api-cpp
%doc %{_datadir}/proton/examples/cpp/*
%files -n python3-qpid-proton
%{python3_sitearch}/*
%files -n python-qpid-proton-help
%defattr(-,root,root,-)
%license %{_datadir}/proton/LICENSE.txt
%doc %{_datadir}/proton/docs/api-py
%doc %{_datadir}/proton/examples/python
%files tests
%license %{_datadir}/proton/LICENSE.txt
%doc %{_datadir}/proton/tests
%changelog
* Thu Nov 07 2024 chenyaqiang <[email protected]> - 0.39.0-1
- Update to 0.39.0:
* Frame dumps truncated if there is a zero length string
* Convert C++ broker example to use lambdas
* Add support for message 'to' to C++ example broker
* remove travis jobs config, infra dropping support for it
* Fix python tests to work with recent pythons and tox
* Remove cmake workarounds that aren't needed anymore
* Tue Feb 07 2023 xu_ping <[email protected]> - 0.38.0-1
- Update to 0.38.0
* Tue Jul 13 2021 huangtianhua <[email protected]> - 0.33.0-1
- Update to 0.33.0
* Tue Aug 10 2021 wangyue <[email protected]> - 0.31.0-2
- Patch for non-constant SIGSTKSZ
* Tue Jun 2 2020 leiju <[email protected]> - 0.31.0-1
- Update to 0.31.0
* Wed Jan 8 2020 Senlin Xia<[email protected]> - 0.24.0-5
- Package init
此处可能存在不合适展示的内容,页面不予展示。您可通过相关编辑功能自查并修改。
如您确认内容无涉及 不当用语 / 纯广告导流 / 暴力 / 低俗色情 / 侵权 / 盗版 / 虚假 / 无价值内容或违法国家有关法律法规的内容,可点击提交进行申诉,我们将尽快为您处理。