1 Star 0 Fork 15

wanglianguo/python-cocotb

加入 Gitee
与超过 1200万 开发者一起发现、参与优秀开源项目,私有仓库也完全免费 :)
免费加入
文件
该仓库未声明开源许可证文件(LICENSE),使用请关注具体项目描述及其代码上游依赖。
克隆/下载
python-cocotb.spec 2.35 KB
一键复制 编辑 原始数据 按行查看 历史
wanglianguo 提交于 2022-07-13 09:35 . Initial source code for python-cocotb
%global _empty_manifest_terminate_build 0
Name: python-cocotb
Version: 1.6.2
Release: 1
Summary: cocotb is a coroutine based cosimulation library for writing VHDL and Verilog testbenches in Python.
License: BSD
URL: https://docs.cocotb.org
Source0: https://files.pythonhosted.org/packages/14/be/8d10d7204e8f02ae45bd37a65b5ba0450806c1e1937b4cb6272567499dd0/cocotb-1.6.2.tar.gz
BuildRequires: python3-devel
BuildRequires: python3dist(setuptools)
BuildRequires: python3dist(setuptools-scm)
BuildRequires: python3dist(pytest)
BuildRequires: gcc, gcc-c++, make
ExcludeArch: s390x
%description
cocotb is a coroutine based cosimulation library for writing VHDL and Verilog testbenches in Python.
%package -n python3-cocotb
Summary: cocotb is a coroutine based cosimulation library for writing VHDL and Verilog testbenches in Python.
Provides: python-cocotb
BuildRequires: python3-devel
BuildRequires: python3-setuptools
%description -n python3-cocotb
cocotb is a coroutine based cosimulation library for writing VHDL and Verilog testbenches in Python.
%package help
Summary: Development documents and examples for cocotb
Provides: python3-cocotb-doc
%description help
cocotb is a coroutine based cosimulation library for writing VHDL and Verilog testbenches in Python.
%prep
%autosetup -n cocotb-1.6.2
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-cocotb -f filelist.lst
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Wed Jul 13 2022 wanglianguo <[email protected]> - 1.6.2-1
- Package Spec generated
Loading...
马建仓 AI 助手
尝试更多
代码解读
代码找茬
代码优化
1
https://gitee.com/wanglianguo/python-cocotb.git
[email protected]:wanglianguo/python-cocotb.git
wanglianguo
python-cocotb
python-cocotb
master

搜索帮助