123 Star 0 Fork 12

src-openEuler/tuna

加入 Gitee
与超过 1200万 开发者一起发现、参与优秀开源项目,私有仓库也完全免费 :)
免费加入
文件
该仓库未声明开源许可证文件(LICENSE),使用请关注具体项目描述及其代码上游依赖。
克隆/下载
tuna.spec 3.92 KB
一键复制 编辑 原始数据 按行查看 历史
Name: tuna
Version: 0.19
Release: 2
Summary: Application tuning GUI & command line utility
License: GPLv2
URL: https://rt.wiki.kernel.org/index.php/Tuna
Source: https://www.kernel.org/pub/software/utils/%{name}/%{name}-%{version}.tar.xz
BuildArch: noarch
BuildRequires: python3-devel gettext
Requires: python3-ethtool python3-linux-procfs >= 0.6 python3-schedutils >= 0.6
%description
Provides interface to change the scheduler and IRQ tunables across the CPU
and below per thread/IRQ level. Allows the CPU to be isolated for specific
applications and drag and drop threads and interrupts to the CPU.
You can complete the operation on the CPU socket to understand the CPU topology.
Can be used as a command line utility without installing a GUI library.
%package -n oscilloscope
Summary: Generic graphical signal plotting tool
Requires: python3-matplotlib-gtk3 python3-numpy python3-cairocffi
Requires: gobject-introspection
Requires: tuna = %{version}-%{release}
%description -n oscilloscope
Plot stream of values read from standard input on the screen,
along with statistics and histograms.
Allows instant viewing of how signal generators (e.g. loop tests,
signaltests or even pings) react when using tuna or regular
chrt & taskket to change their scheduling strategy or real-time priorities.
%package help
Summary: doc for %{name}
%description help
Man manual document for tuna
%prep
%autosetup -p1 -n %{name}-%{version}
%build
%py3_build
pathfix.py -pni "%{__python3} %{py3_shbang_opts}" tuna/
pathfix.py -pni "%{__python3} %{py3_shbang_opts}" tuna-cmd.py
pathfix.py -pni "%{__python3} %{py3_shbang_opts}" oscilloscope-cmd.py
%install
rm -rf %{buildroot}
%py3_install
mkdir -p %{buildroot}/%{_sysconfdir}/tuna/
mkdir -p %{buildroot}/{%{_bindir},%{_datadir}/tuna/help/kthreads,%{_mandir}/man8}
mkdir -p %{buildroot}/%{_datadir}/polkit-1/actions/
install -p -m644 tuna/tuna_gui.glade %{buildroot}/%{_datadir}/tuna/
install -p -m755 tuna-cmd.py %{buildroot}/%{_bindir}/tuna
install -p -m755 oscilloscope-cmd.py %{buildroot}/%{_bindir}/oscilloscope
install -p -m644 help/kthreads/* %{buildroot}/%{_datadir}/tuna/help/kthreads/
install -p -m644 docs/tuna.8 %{buildroot}/%{_mandir}/man8/
#kernel version >= 5.13 Move SCHED_DEBUG sysctl to debugfs
#https://github.com/torvalds/linux/commit/8a99b6833c884fa0e7919030d93fecedc69fc625
sed -i '/kernel.sched_latency_ns/d' etc/tuna/example.conf
sed -i '/kernel.sched_min_granularity_ns/d' etc/tuna/example.conf
sed -i '/kernel.sched_nr_migrate/d' etc/tuna/example.conf
sed -i '/kernel.sched_tunable_scaling/d' etc/tuna/example.conf
sed -i '/kernel.sched_wakeup_granularity_ns/d' etc/tuna/example.conf
sed -i '/kernel.sched_migration_cost_ns/d' etc/tuna/example.conf
install -p -m644 etc/tuna/example.conf %{buildroot}/%{_sysconfdir}/tuna/
install -p -m644 etc/tuna.conf %{buildroot}/%{_sysconfdir}/
install -p -m644 org.tuna.policy %{buildroot}/%{_datadir}/polkit-1/actions/
for lng in `cat po/LINGUAS`; do
po=po/"$lng.po"
install -d %{buildroot}/%{_datadir}/locale/${lng}/LC_MESSAGES
msgfmt $po -o %{buildroot}/%{_datadir}/locale/${lng}/LC_MESSAGES/%{name}.mo
done
%find_lang tuna
%files -f tuna.lang
%defattr(-,root,root,-)
%{python3_sitelib}/*.egg-info
%{_bindir}/tuna
%{_datadir}/tuna/
%{python3_sitelib}/tuna/
%{_sysconfdir}/{tuna.conf,tuna/*}
%{_datadir}/polkit-1/actions/org.tuna.policy
%files -n oscilloscope
%defattr(-,root,root,-)
%{_bindir}/oscilloscope
%doc docs/{oscilloscope+tuna.html,oscilloscope+tuna.pdf}
%files help
%{_mandir}/man8/tuna.8*
%doc ChangeLog
%changelog
* Tue Jan 14 2025 xu_ping <[email protected]> - 0.19-2
- fix tuna apply example.conf failed due to kernel version >=5.13
* Mon Oct 16 2023 chenyaqiang <[email protected]> - 0.19-1
- Upgrade to 0.19
* Fri Sep 11 2020 maminjie <[email protected]> - 0.14.1-1
- Upgrade to 0.14.1
* Thu Mar 5 2020 dingyiming <[email protected]> - 0.13.1-7
- Package init
Loading...
马建仓 AI 助手
尝试更多
代码解读
代码找茬
代码优化
1
https://gitee.com/src-openeuler/tuna.git
[email protected]:src-openeuler/tuna.git
src-openeuler
tuna
tuna
master

搜索帮助