9 Star 0 Fork 17

src-openEuler/pyparsing

加入 Gitee
与超过 1200万 开发者一起发现、参与优秀开源项目,私有仓库也完全免费 :)
免费加入
文件
该仓库未声明开源许可证文件(LICENSE),使用请关注具体项目描述及其代码上游依赖。
克隆/下载
pyparsing.spec 4.18 KB
一键复制 编辑 原始数据 按行查看 历史
lixiaoyong1 提交于 2024-10-15 07:27 . Upgrade package to version 3.2.0
Name: pyparsing
Version: 3.2.0
Release: 1
Summary: A Python Parsing Module
License: MIT
URL: https://github.com/pyparsing/pyparsing/
Source0: https://github.com/pyparsing/pyparsing/releases/download/%{version}/pyparsing-%{version}.tar.gz
BuildArch: noarch
BuildRequires: dos2unix python3-devel python3-setuptools python3-tox python3-coverage python3-flit-core
BuildRequires: python%{python3_pkgversion}-pip python%{python3_pkgversion}-wheel
%description
The pyparsing module is an alternative approach to creating and executing simple
grammars, vs. the traditional lex/yacc approach, or the use of regular expressions.
The pyparsing module provides a library of classes that client code uses to
construct the grammar directly in Python code.
%package -n python3-pyparsing
Summary: Pyparsing for python3
Provides: python%{python3_pkgversion}dist(pyparsing) = %{version}
Provides: python%{python3_version}dist(pyparsing) = %{version}
%{?python_provide:%python_provide python3-%pyparsing}
%description -n python3-pyparsing
pyparsing is a module that can be used to easily and directly configure syntax
definitions for any number of text parsing applications.
%package help
Summary: Documents for %{name}
Buildarch: noarch
Requires: man info
Provides: pyparsing-doc
Obsoletes: pyparsing-doc
%description help
Man pages and other related documents for %{name}.
%prep
%autosetup -n %{name}-%{version}
dos2unix -k CHANGES LICENSE
%build
%pyproject_build
%install
%pyproject_install
%check
%{__python3} tests/test_simple_unit.py
%pre
%preun
%post
%postun
%files -n python3-pyparsing
%license LICENSE
%doc CHANGES README.rst
%{python3_sitelib}/pyparsing/
%{python3_sitelib}/pyparsing-*dist-info/
%files help
%doc CHANGES README.rst docs examples
%changelog
* Tue Oct 15 2024 lixiaoyong <[email protected]> - 3.2.0-1
- Upgrade package to version 3.2.0
- Discontinued support for Python 3.6, 3.7, and 3.8. Adopted new Python features from
Python versions 3.7-3.9
- Fixed code in `ParseElementEnhance` subclasses
- Added new `Tag` ParserElement, for inserting metadata into the parsed results
- Fixed a regression introduced in pyparsing 3.1.3, addition of a type annotation that
referenced `re.Pattern`
* Thu Aug 15 2024 dillon chen <[email protected]> - 3.1.2-1
- update version to 3.1.2
* Mon Jan 29 2024 yixiangzhike <[email protected]> - 3.1.1-1
- update version to 3.1.1
- Fixed bug in NotAny where expr parse action was not being run
- Fix regex matching for Python quoted strings
- Make create_diagram() code compatible with latest version of railroad-diagrams
- Support Python 3.12
- Small perf optimization for `expr | ""` mapping to `Optional(expr)`
- Redo QuotedString '\' escape handling as a state machine
- Add ParseResults.deepcopy()
- Remove ^ and $ tags from pp.common.url regex
- Added DelimitedList class, for better handling of naming and diagramming
- Deprecate ParserElement.validate()
- Added new class method ParserElement.using_each
- Fix bug in delimited_list
- Added python_quoted_string; fixed exception messages for ParseElementEnhance subclasses
- Enable packrat in verilogParse.py by default
- Add embed argument to create_diagram
- Add support for slice in expr[] notation
- Fixed bug in srange
- Added Lox language parser
* Fri Jul 28 2023 zhuofeng <[email protected]> - 3.0.9-1
- update version to 3.0.9
* Sat May 27 2023 yanglongkang <[email protected]> - 3.0.7-2
- enable check
* Fri Jul 01 2022 wangkuntian <[email protected]> - 3.0.7-1
- Upgrade package pyparsing to version 3.0.7
* Wed Dec 01 2021 shixuantong <[email protected]> - 3.0.6-1
- update version to 3.0.6
* Sat Sep 5 2020 shixuantong <[email protected]> - 2.4.7-3
- Type: bugfix
- ID: NA
- SUG: NA
- DESC: update Source0
* Fri Aug 7 2020 wenzhanli<[email protected]> - 2.4.7-2
- Type:bugfix
- ID:NAl
- SUG:NA
- DESC:remove python2 require
* Fri Jul 17 2020 shixuantong <[email protected]> -2.4.7-1
- update to 2.4.7-1
* Fri Sep 20 2019 openEuler Buildteam <[email protected]> - 2.2.0-4
- Package init
Loading...
马建仓 AI 助手
尝试更多
代码解读
代码找茬
代码优化
1
https://gitee.com/src-openeuler/pyparsing.git
[email protected]:src-openeuler/pyparsing.git
src-openeuler
pyparsing
pyparsing
master

搜索帮助