代码拉取完成,页面将自动刷新
Name: pyparsing
Version: 3.2.0
Release: 1
Summary: A Python Parsing Module
License: MIT
URL: https://github.com/pyparsing/pyparsing/
Source0: https://github.com/pyparsing/pyparsing/releases/download/%{version}/pyparsing-%{version}.tar.gz
BuildArch: noarch
BuildRequires: dos2unix python3-devel python3-setuptools python3-tox python3-coverage python3-flit-core
BuildRequires: python%{python3_pkgversion}-pip python%{python3_pkgversion}-wheel
%description
The pyparsing module is an alternative approach to creating and executing simple
grammars, vs. the traditional lex/yacc approach, or the use of regular expressions.
The pyparsing module provides a library of classes that client code uses to
construct the grammar directly in Python code.
%package -n python3-pyparsing
Summary: Pyparsing for python3
Provides: python%{python3_pkgversion}dist(pyparsing) = %{version}
Provides: python%{python3_version}dist(pyparsing) = %{version}
%{?python_provide:%python_provide python3-%pyparsing}
%description -n python3-pyparsing
pyparsing is a module that can be used to easily and directly configure syntax
definitions for any number of text parsing applications.
%package help
Summary: Documents for %{name}
Buildarch: noarch
Requires: man info
Provides: pyparsing-doc
Obsoletes: pyparsing-doc
%description help
Man pages and other related documents for %{name}.
%prep
%autosetup -n %{name}-%{version}
dos2unix -k CHANGES LICENSE
%build
%pyproject_build
%install
%pyproject_install
%check
%{__python3} tests/test_simple_unit.py
%pre
%preun
%post
%postun
%files -n python3-pyparsing
%license LICENSE
%doc CHANGES README.rst
%{python3_sitelib}/pyparsing/
%{python3_sitelib}/pyparsing-*dist-info/
%files help
%doc CHANGES README.rst docs examples
%changelog
* Tue Oct 15 2024 lixiaoyong <[email protected]> - 3.2.0-1
- Upgrade package to version 3.2.0
- Discontinued support for Python 3.6, 3.7, and 3.8. Adopted new Python features from
Python versions 3.7-3.9
- Fixed code in `ParseElementEnhance` subclasses
- Added new `Tag` ParserElement, for inserting metadata into the parsed results
- Fixed a regression introduced in pyparsing 3.1.3, addition of a type annotation that
referenced `re.Pattern`
* Thu Aug 15 2024 dillon chen <[email protected]> - 3.1.2-1
- update version to 3.1.2
* Mon Jan 29 2024 yixiangzhike <[email protected]> - 3.1.1-1
- update version to 3.1.1
- Fixed bug in NotAny where expr parse action was not being run
- Fix regex matching for Python quoted strings
- Make create_diagram() code compatible with latest version of railroad-diagrams
- Support Python 3.12
- Small perf optimization for `expr | ""` mapping to `Optional(expr)`
- Redo QuotedString '\' escape handling as a state machine
- Add ParseResults.deepcopy()
- Remove ^ and $ tags from pp.common.url regex
- Added DelimitedList class, for better handling of naming and diagramming
- Deprecate ParserElement.validate()
- Added new class method ParserElement.using_each
- Fix bug in delimited_list
- Added python_quoted_string; fixed exception messages for ParseElementEnhance subclasses
- Enable packrat in verilogParse.py by default
- Add embed argument to create_diagram
- Add support for slice in expr[] notation
- Fixed bug in srange
- Added Lox language parser
* Fri Jul 28 2023 zhuofeng <[email protected]> - 3.0.9-1
- update version to 3.0.9
* Sat May 27 2023 yanglongkang <[email protected]> - 3.0.7-2
- enable check
* Fri Jul 01 2022 wangkuntian <[email protected]> - 3.0.7-1
- Upgrade package pyparsing to version 3.0.7
* Wed Dec 01 2021 shixuantong <[email protected]> - 3.0.6-1
- update version to 3.0.6
* Sat Sep 5 2020 shixuantong <[email protected]> - 2.4.7-3
- Type: bugfix
- ID: NA
- SUG: NA
- DESC: update Source0
* Fri Aug 7 2020 wenzhanli<[email protected]> - 2.4.7-2
- Type:bugfix
- ID:NAl
- SUG:NA
- DESC:remove python2 require
* Fri Jul 17 2020 shixuantong <[email protected]> -2.4.7-1
- update to 2.4.7-1
* Fri Sep 20 2019 openEuler Buildteam <[email protected]> - 2.2.0-4
- Package init
此处可能存在不合适展示的内容,页面不予展示。您可通过相关编辑功能自查并修改。
如您确认内容无涉及 不当用语 / 纯广告导流 / 暴力 / 低俗色情 / 侵权 / 盗版 / 虚假 / 无价值内容或违法国家有关法律法规的内容,可点击提交进行申诉,我们将尽快为您处理。