6 Star 0 Fork 3

src-openEuler/poissonsearch-py

加入 Gitee
与超过 1200万 开发者一起发现、参与优秀开源项目,私有仓库也完全免费 :)
免费加入
文件
克隆/下载
poissonsearch-py.spec 2.87 KB
一键复制 编辑 原始数据 按行查看 历史
zhangxianting 提交于 2024-04-11 13:41 +08:00 . fix empty doclist.lst
%global _empty_manifest_terminate_build 0
Name: poissonsearch-py
Version: 1.0.0
%define package_version 1.0.0-alpha1
Release: 2
Summary: Python client for Elasticsearch
License: Apache-2.0
URL: https://gitee.com/openeuler/poissonsearch-py
Source0: https://gitee.com/openeuler/poissonsearch-py/archive/refs/tags/%{package_version}.tar.gz
BuildArch: noarch
BuildRequires: python3-urllib3
Requires: python3-certifi
BuildRequires: python3-mock
BuildRequires: python3-numpy
BuildRequires: python3-pandas
BuildRequires: python3-pytest
%description
Official low-level client for Elasticsearch, forked from elastic/elasticsearch-py 7.10.1. Its goal is to provide common
ground for all Elasticsearch-related code in Python; because of this it tries
to be opinion-free and very extendable.
%package -n python3-poissonsearch-py
Summary: Python client for Elasticsearch
Provides: elasticsearch-py = 7.10.1
BuildRequires: python3-devel
BuildRequires: python3-setuptools
%description -n python3-poissonsearch-py
Official low-level client for Elasticsearch. Its goal is to provide common
ground for all Elasticsearch-related code in Python; because of this it tries
to be opinion-free and very extendable.
%package help
Summary: Development documents and examples for elasticsearch
Provides: python3-poissonsearch-py-doc
%description help
Official low-level client for Elasticsearch. Its goal is to provide common
ground for all Elasticsearch-related code in Python; because of this it tries
to be opinion-free and very extendable.
%prep
%autosetup -n %{package_version}
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%check
pushd test_elasticsearch
pytest test_serializer.py
pytest test_helpers.py
pytest test_connection_pool.py
pytest test_cases.py
pushd ../
%files -n python3-poissonsearch-py -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Thu Apr 11 2024 zhangxianting <[email protected]> - 1.0.0-2
- fix empty doclist.lst
* Wed Feb 28 2024 linshoubao <[email protected]> - 1.0.0-1
- Package Spec generated
Loading...
马建仓 AI 助手
尝试更多
代码解读
代码找茬
代码优化
1
https://gitee.com/src-openeuler/poissonsearch-py.git
[email protected]:src-openeuler/poissonsearch-py.git
src-openeuler
poissonsearch-py
poissonsearch-py
master

搜索帮助