5 Star 0 Fork 12

src-openEuler/lz4-java

加入 Gitee
与超过 1200万 开发者一起发现、参与优秀开源项目,私有仓库也完全免费 :)
免费加入
文件
该仓库未声明开源许可证文件(LICENSE),使用请关注具体项目描述及其代码上游依赖。
克隆/下载
lz4-java.spec 3.14 KB
一键复制 编辑 原始数据 按行查看 历史
zke 提交于 2024-02-22 17:45 . riscv64: update jdk to version 11
%global debug_package %nil
Name: lz4-java
Version: 1.8.0
Release: 2
Summary: LZ4 compression for Java
License: Apache-2.0
URL: https://github.com/jpountz/lz4-java
Source0: https://github.com/jpountz/lz4-java/archive/%{version}.tar.gz
Patch1: 1-remove-comments-from-templates.patch
Patch2: 2-remove-cpptasks.patch
BuildRequires: java-devel >= 1:11.0.0
BuildRequires: ant ant-junit aqute-bnd cpptasks ivy-local javapackages-local mvel gcc xxhash-devel
BuildRequires: objectweb-asm randomizedtesting-junit4-ant bea-stax-api xerces-j2 apache-parent lz4 lz4-devel
Requires: javapackages-tools
Provides: bundled(lz4) = r122
Provides: bundled(libxxhash) = r37
%description
LZ4 compression for Java, based on Yann Collet's work.
This library provides access to two compression methods
that both generate a valid LZ4 stream:
* fast scan (LZ4):
° low memory footprint (~ 16 KB),
° very fast (fast scan with skipping heuristics in case the
input looks incompressible),
° reasonable compression ratio (depending on the
redundancy of the input).
* high compression (LZ4 HC):
° medium memory footprint (~ 256 KB),
° rather slow (~ 10 times slower than LZ4),
° good compression ratio (depending on the size and
the redundancy of the input).
The streams produced by those 2 compression algorithms use the
same compression format, are very fast to decompress and can be
decompressed by the same decompressor instance.
%package javadoc
Summary: Javadoc for %{name}
BuildArch: noarch
%description javadoc
This package contains javadoc for %{name}.
%prep
%autosetup -n %{name}-%{version} -p1
find -name '*.dylib' -print -delete
find -name '*.so' -print -delete
%build
pushd /usr/lib/jvm
dirname=`ls | grep java-11-openjdk-`
javapath=/usr/lib/jvm/$dirname
popd
export JAVA_HOME=$javapath
export LIB_DIR=/usr/lib64/
sed -i '$a\ strip $(BUILD_DIR)/jni/net/jpountz/util/$(PLATFORM)/$(ARCH)/liblz4-java.so' Makefile
ant -Divy.mode=local -Divy.revision=%{version} -Divy.pom.version=%{version} jar test docs makepom
bnd wrap -p lz4-java.bnd -o dist/lz4-java-%{version}.jar --version %{version} dist/lz4-java.jar
%install
%mvn_artifact dist/lz4-java-%{version}.pom dist/lz4-java-%{version}.jar
%mvn_install -J build/docs
%files -f .mfiles
%doc CHANGES.md README.md
%license LICENSE.txt
%files javadoc -f .mfiles-javadoc
%license LICENSE.txt
%changelog
* Thu Feb 22 2024 zke_012020 <[email protected]> - 1.8.0-2
- Upgrade JDK version to 11
* Thu Jul 27 2023 chenchen <[email protected]> - 1.8.0-1
- Upgrade version to 1.8.0
* Fri Mar 3 2023 caodongxia <[email protected]> - 1.7.1-3
- Fix not stripped problem
* Tue May 10 2022 wangkai <[email protected]> - 1.7.1-2
- License compliance rectification
* Tue Jan 18 2022 SimpleUpdate Robot <[email protected]> - 1.7.1-1
- Upgrade to version 1.7.1
* Wed Jun 09 2021 wulei <[email protected]> - 1.3.0-2
- fixes failed: Could not launch gcc
* Tue Aug 25 2020 Jeffery.Gao <[email protected]> - 1.3.0-1
- Package init
Loading...
马建仓 AI 助手
尝试更多
代码解读
代码找茬
代码优化
1
https://gitee.com/src-openeuler/lz4-java.git
[email protected]:src-openeuler/lz4-java.git
src-openeuler
lz4-java
lz4-java
master

搜索帮助