13 Star 0 Fork 24

src-openEuler/libjpeg-turbo

加入 Gitee
与超过 1200万 开发者一起发现、参与优秀开源项目,私有仓库也完全免费 :)
免费加入
文件
该仓库未声明开源许可证文件(LICENSE),使用请关注具体项目描述及其代码上游依赖。
克隆/下载
libjpeg-turbo.spec 5.51 KB
一键复制 编辑 原始数据 按行查看 历史
Funda Wang 提交于 2024-12-26 09:35 . 3.1.0
Name: libjpeg-turbo
Version: 3.1.0
Release: 1
Summary: MMX/SSE2/SIMD accelerated libjpeg-compatible JPEG codec library
License: IJG
URL: https://libjpeg-turbo.org/
Source0: https://github.com/libjpeg-turbo/libjpeg-turbo/releases/download/%{version}/%{name}-%{version}.tar.gz
Patch0001: libjpeg-turbo-add-loongarch64-and-riscv64.patch
BuildRequires: gcc cmake nasm
Obsoletes: libjpeg < 6b-47 turbojpeg < %{version}-%{release}
Provides: libjpeg = 6b-47 turbojpeg = %{version}-%{release}
%description
libjpeg-turbo is a JPEG image codec that uses SIMD instructions (MMX, SSE2, NEON, AltiVec)
to accelerate baseline JPEG compression and decompression on x86, x86-64, and ARM systems.
%package devel
Summary: Development files for the libjpeg-turbo library
Requires: libjpeg-turbo = %{version}-%{release}
Provides: libjpeg-turbo-static = 1.3.1 turbojpeg-devel = %{version}-%{release}
Obsoletes: libjpeg-turbo-static < 1.3.1 turbojpeg-devel < %{version}-%{release}
Provides: libjpeg-devel = 6b-47 libjpeg-devel%{?_isa} = %{version}-%{release}
Obsoletes: libjpeg-devel < 6b-47
%description devel
Development files for the libjpeg-turbo library.
%package utils
Summary: Utilities for manipulating JPEG images
Requires: libjpeg-turbo%{?_isa} = %{version}-%{release}
%description utils
The libjpeg-turbo-utils package contains simple client programs for accessing
the libjpeg functions. It contains cjpeg, djpeg, jpegtran, rdjpgcom and
wrjpgcom. Cjpeg compresses an image file into JPEG format. Djpeg decompresses a
JPEG file into a regular image file. Jpegtran can perform various useful
transformations on JPEG files. Rdjpgcom displays any text comments included in a
JPEG file. Wrjpgcom inserts text comments into a JPEG file.
%package -n turbojpeg
Summary: TurboJPEG library
%description -n turbojpeg
The turbojpeg package contains the TurboJPEG shared library.
%package -n turbojpeg-devel
Summary: Headers for the TurboJPEG library
Requires: turbojpeg%{?_isa} = %{version}-%{release}
%description -n turbojpeg-devel
This package contains header files necessary for developing programs which will
manipulate JPEG files using the TurboJPEG library.
%package_help
%prep
%autosetup -n %{name}-%{version} -p1
%build
%{cmake} \
-DCMAKE_INSTALL_LIBDIR=%{_libdir} -DCMAKE_SKIP_RPATH:BOOL=YES -DCMAKE_SKIP_INSTALL_RPATH:BOOL=YES -DENABLE_STATIC:BOOL=NO \
%{nil}
%cmake_build
%install
%cmake_install
rm -fr %{buildroot}%{_datadir}/doc/libjpeg-turbo
chmod -x README.md
%ifarch %{ix86}
%global wordsize ""
%else
%global wordsize "64"
%endif
if test -n "$wordsize"
then
pushd $RPM_BUILD_ROOT%{_includedir}
mv jconfig.h jconfig-$wordsize.h
cat > jconfig.h <<EOF
#ifndef JCONFIG_H_MULTILIB
#define JCONFIG_H_MULTILIB
#include <bits/wordsize.h>
#if __WORDSIZE == 32
# include "jconfig-32.h"
#elif __WORDSIZE == 64
# include "jconfig-64.h"
#else
# error "unexpected value for __WORDSIZE macro"
#endif
#endif
EOF
fi
%check
export LD_LIBRARY_PATH=%{buildroot}%{_libdir}
%ctest
%files
%doc README.*
%license LICENSE.md
%{_libdir}/libjpeg.so.62*
%files devel
%doc doc/coderules.txt doc/libjpeg.txt doc/structure.txt src/jconfig.txt
%{_includedir}/jconfig.h
%{_includedir}/jerror.h
%{_includedir}/jmorecfg.h
%{_includedir}/jpeglib.h
%{_libdir}/libjpeg.so
%{_libdir}/pkgconfig/libjpeg.pc
%{_libdir}/cmake/%{name}
%files utils
%doc doc/usage.txt doc/wizard.txt
%{_bindir}/cjpeg
%{_bindir}/djpeg
%{_bindir}/jpegtran
%{_bindir}/rdjpgcom
%{_bindir}/wrjpgcom
%{_bindir}/tjbench
%files -n turbojpeg
%license LICENSE.md
%{_libdir}/libturbojpeg.so.0*
%files -n turbojpeg-devel
%{_includedir}/turbojpeg.h
%{_libdir}/libturbojpeg.so
%{_libdir}/pkgconfig/libturbojpeg.pc
%files help
%doc ChangeLog.md
%{_mandir}/man1/*.1*
%changelog
* Thu Dec 26 2024 Funda Wang <[email protected]> - 3.1.0-1
- update to 3.1.0
* Tue Sep 17 2024 Funda Wang <[email protected]> - 3.0.4-1
- update to 3.0.4
* Tue Apr 16 2024 Wenlong Zhang <[email protected]> - 3.0.1-2
- add loongarch64 support for libjpeg-turbo
* Mon Jan 8 2024 zhangpan <[email protected]> - 3.0.1-1
- update to 3.0.1
* Fri Jul 21 2023 zhangpan <[email protected]> - 3.0.0-1
- update to 3.0.0
* Mon Jul 10 2023 Jingwiw <[email protected]> - 2.1.1-6
- add riscv64 support
* Mon Apr 24 2023 guoqinglan <[email protected]> - 2.1.1-5
- fix build error for sw_64
* Thu Nov 17 2022 doupengda <[email protected]> - 2.1.1-4
- add loongarch64 support
* Wed Jul 13 2022 wangkerong <[email protected]> - 2.1.1-3
- utils provide by libjpeg-turbo-utils subpackage,the main package shouldn't provide it
* Wed Mar 30 2022 liuyumeng <[email protected]> - 2.1.1-2
- enable tests
* Sat Nov 27 2021 wangkerong <[email protected]> - 2.1.1-1
- update to 2.1.1
- splite utils turbojpeg turbojpeg-devel subpackages
* Wed Jan 27 2021 hanhui <[email protected]> - 2.0.6-1
- Type: enhancement
- ID: NA
- SUG: NA
- DESC: update to 2.0.6
* Wed Jul 22 2020 openEuler Buildteam <[email protected]> - 2.0.5-1
- Type:enhancement
- Id:NA
- SUG:NA
- DESC:upgrade to 2.0.5
* Tue Jan 14 2020 openEuler Buildteam <[email protected]> - 2.0.0-4
- Type:bugfix
- Id:NA
- SUG:NA
- DESC:remove the libjpeg-devel with arch in obsoletes
* Fri Nov 1 2019 openEuler Buildteam <[email protected]> - 2.0.0-3
- Type:bugfix
- Id:NA
- SUG:NA
- DESC:add the libjpeg-devel and jconfig.h
* Sat Sep 21 2019 Lijin Yang <[email protected]> - 2.0.0-2
- Package init
Loading...
马建仓 AI 助手
尝试更多
代码解读
代码找茬
代码优化
1
https://gitee.com/src-openeuler/libjpeg-turbo.git
[email protected]:src-openeuler/libjpeg-turbo.git
src-openeuler
libjpeg-turbo
libjpeg-turbo
master

搜索帮助