代码拉取完成,页面将自动刷新
Name: dbus
Epoch: 1
Version: 1.16.0
Release: 1
Summary: System Message Bus
License: (AFL-2.1 OR GPL-2.0-or-later) AND GPL-2.0-or-later
URL: https://www.freedesktop.org/Software/dbus/
Source0: https://dbus.freedesktop.org/releases/dbus/%{name}-%{version}.tar.xz
Source1: 00-start-message-bus.sh
Patch0001: bugfix-let-systemd-restart-dbus-when-the-it-enters-failed.patch
Patch0002: print-load-average-when-activate-service-timeout.patch
Patch6001: backport-tools-Use-Python3-for-GetAllMatchRules.patch
BuildRequires: gcc make
BuildRequires: meson >= 0.56
BuildRequires: xmlto
BuildRequires: /usr/bin/doxygen
BuildRequires: /usr/bin/ducktype
BuildRequires: /usr/bin/xsltproc
BuildRequires: /usr/bin/yelp-build
BuildRequires: pkgconfig(expat)
BuildRequires: pkgconfig(gio-unix-2.0)
BuildRequires: pkgconfig(glib-2.0) >= 2.40
BuildRequires: pkgconfig(libselinux) >= 2.0.86
BuildRequires: pkgconfig(libsystemd) >= 209
BuildRequires: pkgconfig(systemd)
BuildRequires: pkgconfig(x11)
BuildRequires: audit-libs-devel
BuildRequires: libcap-ng-devel
BuildRequires: cmake-rpm-macros
Requires: %{name}-daemon = %{epoch}:%{version}-%{release}
%description
D-Bus is a message bus system, a simple way for applications to talk to one another.
In addition to interprocess communication, D-Bus helps coordinate process lifecycle;
it makes it simple and reliable to code a "single instance" application or daemon,
and to launch applications and daemons on demand when their services are needed.
%package libs
Summary: Libraries for D-BUS
%description libs
This package contains libraries for D-BUS.
%package daemon
Summary: D-BUS message bus
Requires(pre): shadow
Requires(post): systemd
Requires(preun): systemd
Requires(postun): systemd
Requires: libselinux systemd
Requires: dbus-common = %{epoch}:%{version}-%{release}
Requires: dbus-libs = %{epoch}:%{version}-%{release}
Requires: dbus-tools = %{epoch}:%{version}-%{release}
%description daemon
D-Bus is a message bus system, a simple way for applications to talk to one another.
In addition to interprocess communication, D-Bus helps coordinate process lifecycle;
it makes it simple and reliable to code a "single instance" application or daemon,
and to launch applications and daemons on demand when their services are needed.
%package common
Summary: dbus configuration
BuildArch: noarch
Requires: systemd
Requires(post): systemd
Requires(preun): systemd
Requires(postun): systemd
%description common
This package contains the configuration and setup files for D-Bus.
%package tools
Summary: dbus tools
Requires: dbus-libs = %{epoch}:%{version}-%{release}
%description tools
This package contains the tools and utilities to interact
with a running D-Bus Message Bus.
%package devel
Summary: Development files for developers
Requires: %{name}-libs = %{epoch}:%{version}-%{release} xml-common
%description devel
This package contains development files for developers.
%package x11
Summary: X11-requiring for D-BUS
Requires: %{name}-daemon = %{epoch}:%{version}-%{release}
%description x11
This pacakge contains the tools that needed to be install for Xlib.
%package help
Summary: Man pages and other related documents for D-Bus
BuildArch: noarch
Obsoletes: %{name}-doc
%description help
Man pages and other related documents for D-Bus.
%prep
%autosetup -n %{name}-%{version} -p1
%build
%meson \
-Dlibaudit=enabled \
-Dselinux=enabled \
-Dsystem_socket=%{_localstatedir}/run/dbus/system_bus_socket \
-Ddbus_user=dbus \
-Duser_session=true \
-Dinstalled_tests=false \
-Ddoxygen_docs=enabled \
-Dducktype_docs=enabled \
-Dxml_docs=enabled \
-Dasserts=false \
-Dqt_help=disabled \
-Dapparmor=disabled \
-Dkqueue=disabled \
-Dlaunchd=disabled \
--libexecdir=%{_libexecdir}/dbus-1
%meson_build
%install
%meson_install
install -Dp -m755 %{SOURCE1} %{buildroot}%{_sysconfdir}/X11/xinit/xinitrc.d/00-start-message-bus.sh
install -d $RPM_BUILD_ROOT%{_sysconfdir}/dbus-1/session.d
install -d $RPM_BUILD_ROOT%{_sysconfdir}/dbus-1/system.d
install -d $RPM_BUILD_ROOT%{_datadir}/dbus-1/interfaces
install -d $RPM_BUILD_ROOT%{_localstatedir}/run/dbus
install -d $RPM_BUILD_ROOT%{_localstatedir}/lib/dbus
%pre daemon
# Add the "dbus" user and group
getent group dbus > /dev/null || groupadd -f -g 81 -r dbus
if ! getent passwd dbus > /dev/null ; then
if ! getent passwd 81 > /dev/null ; then
useradd -r -u 81 -c 'D-Bus' -g dbus -s /sbin/nologin -d %{_localstatedir}/run/dbus dbus
else
useradd -r -g dbus -c 'D-Bus' -s /sbin/nologin -d %{_localstatedir}/run/dbus dbus
fi
fi
%preun daemon
%systemd_preun dbus.service dbus.socket
%systemd_user_preun dbus.service dbus.socket
%post daemon
%systemd_post dbus.service dbus.socket
%systemd_user_post dbus.service dbus.socket
%postun daemon
%systemd_postun dbus.service dbus.socket
%systemd_user_postun dbus.service dbus.socket
%files
%license COPYING
%doc AUTHORS NEWS README
%files libs
%license COPYING
%{_libdir}/*dbus-1*.so.*
%files daemon
%license COPYING
%doc AUTHORS NEWS README
%ghost %dir /run/%{name}
%dir %{_localstatedir}/lib/dbus/
%{_tmpfilesdir}/dbus.conf
%{_unitdir}/dbus.service
%{_unitdir}/dbus.socket
%{_unitdir}/multi-user.target.wants/dbus.service
%{_unitdir}/sockets.target.wants/dbus.socket
%{_userunitdir}/dbus.service
%{_userunitdir}/dbus.socket
%{_userunitdir}/sockets.target.wants/dbus.socket
%dir %{_libexecdir}/dbus-1
%attr(4750,root,dbus) %{_libexecdir}/dbus-1/dbus-daemon-launch-helper
%{_bindir}/dbus-daemon
%{_bindir}/dbus-cleanup-sockets
%{_bindir}/dbus-run-session
%{_bindir}/dbus-test-tool
%files common
%dir %{_sysconfdir}/dbus-1
%dir %{_sysconfdir}/dbus-1/session.d
%dir %{_sysconfdir}/dbus-1/system.d
%config %{_sysconfdir}/dbus-1/session.conf
%config %{_sysconfdir}/dbus-1/system.conf
%dir %{_datadir}/dbus-1
%{_datadir}/dbus-1/session.conf
%{_datadir}/dbus-1/system.conf
%{_datadir}/dbus-1/services
%{_datadir}/dbus-1/system-services
%{_datadir}/dbus-1/interfaces
%{_sysusersdir}/dbus.conf
%files tools
%{_bindir}/dbus-send
%{_bindir}/dbus-monitor
%{_bindir}/dbus-update-activation-environment
%{_bindir}/dbus-uuidgen
%files x11
%{_bindir}/dbus-launch
%{_sysconfdir}/X11/xinit/xinitrc.d/00-start-message-bus.sh
%files devel
%{_includedir}/*
%{_libdir}/libdbus-1.so
%dir %{_libdir}/dbus-1.0
%{_libdir}/dbus-1.0/include
%{_datadir}/xml/dbus-1
%{_libdir}/cmake/DBus1
%{_libdir}/pkgconfig/dbus-1.pc
%files help
%{_mandir}/man1/dbus-*
%{_docdir}/%{name}/api
%{_docdir}/%{name}/examples
%{_docdir}/%{name}/*.css
%{_docdir}/%{name}/*.devhelp2
%{_docdir}/%{name}/*.html
%{_docdir}/%{name}/*.js
%{_docdir}/%{name}/*.png
%{_docdir}/%{name}/*.svg
%{_docdir}/%{name}/*.txt
%changelog
* Thu Dec 19 2024 Funda Wang <[email protected]> - 1:1.16.0-1
- update to 1.16.0
* Fri Aug 09 2024 Funda Wang <[email protected]> - 1:1.14.10-1
- update to 1.14.10
* Wed Jul 31 2024 hongjinghao <[email protected]> - 1:1.14.8-3
- sync patch from upstream
backport-bus-Don-t-crash-if-bus_context_create_client_policy-.patch
backport-bus-When-failing-to-reload-client-policy-continue-it.patch
backport-test-Add-a-targeted-test-for-_dbus_unix_groups_from_.patch
backport-userdb-Add-proper-error-reporting-when-getting-group.patch
* Wed Feb 21 2024 hongjinghao <[email protected]> - 1:1.14.8-2
- add backport-Do-not-crash-when-reloading-configuration.patch
* Fri Jul 14 2023 hongjinghao <[email protected]> - 1:1.14.8-1
- Update to 1.14.8
* Fri Jun 9 2023 hongjinghao <[email protected]> - 1:1.14.0-3
- fix CVE-2023-34969
* Fri Oct 14 2022 hongjinghao <[email protected]> - 1:1.14.0-2
- fix CVE-2022-42010,CVE-2022-42011,CVE-2022-42012
* Tue Jun 21 2022 fushanqing <[email protected]> - 1:1.14.0-1
- Update to 1.14.0
* Sat Jan 29 2022 licunlong <[email protected]> - 1:1.12.20-6
- Tell systemd when dbus is ready/shutting down/reloading config.
* Tue Nov 30 2021 xuxiaozhou <[email protected]> - 1:1.12.20-5
- add print-load-average-when-activate-service-timeout.patch for more debug information
* Thu Jul 22 2021 yangmingtai <[email protected]> - 1:1.12.20-4
- remove build requires of gdb
* Tue Mar 16 2021 Anakin Zhang <[email protected]> - 1:1.12.20-3
- change dbus group ID to 81
* Fri Nov 13 2020 xielh2000 <[email protected]> - 1:1.12.20-2
- Add from 1.12.16 to 1.12.20 of changelog and README.en
* Wed Jul 15 2020 shenyangyang <[email protected]> - 1:1.12.20-1
- Upgrade to 1.12.20
* Wed Jul 1 2020 shenyangyang <[email protected]> - 1:1.12.18-1
- Upgrade to 1.12.18
* Mon Jun 22 2020 shenyangyang <[email protected]> - 1:1.12.16-15
- Add more test cases modify for solving CVE-2020-12049
* Sat Jun 20 2020 shenyangyang <[email protected]> - 1:1.12.16-14
- Fix CVE-2020-12049
* Sat Mar 21 2020 openEuler Buildteam <[email protected]> - 1:1.12.16-13
- Add build requires of gdb
* Mon Jan 20 2020 openEuler Buildteam <[email protected]> - 1:1.12.16-12
- add requires for dbus-daemon
* Mon Jan 20 2020 openEuler Buildteam <[email protected]> - 1:1.12.16-11
- add package of dbus-x11
* Sun Jan 19 2020 openEuler Buildteam <[email protected]> - 1:1.12.16-10
- add package of dbus-tools and dbus-common
* Sat Jan 18 2020 openEuler Buildteam <[email protected]> - 1:1.12.16-9
- add requires of systemd
* Sat Jan 18 2020 openEuler Buildteam <[email protected]> - 1:1.12.16-8
- add package of dbus-daemon
* Fri Jan 17 2020 openEuler Buildteam <[email protected]> - 1:1.12.16-7
- delete unneeded obsolets and add requires
* Fri Jan 17 2020 openEuler Buildteam <[email protected]> - 1:1.12.16-6
- add package of dbus-libs
* Thu Jan 9 2020 hexiaowen <[email protected]> - 1:1.12.16-5
- delete messagebus.service
* Tue Sep 24 2019 openEuler Buildteam <[email protected]> - 1:1.12.16-4
- Add build requires to add runtime requires and add a start-message-bus.sh
* Tue Sep 24 2019 openEuler Buildteam <[email protected]> - 1:1.12.16-3
- Adjust requires 'shadow-utils' to 'shadow'
* Fri Sep 20 2019 openEuler Buildteam <[email protected]> - 1:1.12.16-2
- Modify license 'and' to 'or'
* Thu Aug 29 2019 openEuler Buildteam <[email protected]> - 1:1.12.16-1
- Package init
此处可能存在不合适展示的内容,页面不予展示。您可通过相关编辑功能自查并修改。
如您确认内容无涉及 不当用语 / 纯广告导流 / 暴力 / 低俗色情 / 侵权 / 盗版 / 虚假 / 无价值内容或违法国家有关法律法规的内容,可点击提交进行申诉,我们将尽快为您处理。