1 Star 0 Fork 15

src-oepkgs-oE-rv/python-py

forked from src-openEuler/python-py 
加入 Gitee
与超过 1200万 开发者一起发现、参与优秀开源项目,私有仓库也完全免费 :)
免费加入
文件
该仓库未声明开源许可证文件(LICENSE),使用请关注具体项目描述及其代码上游依赖。
克隆/下载
python-py.spec 2.69 KB
一键复制 编辑 原始数据 按行查看 历史
李佳伟 提交于 2021-08-10 20:56 . update version to 1.10.0
%bcond_with tests
%global with_help 1
%global modname py
%global modnameversion %{modname}-%{version}
%global p2builddir python2tmp
%global p3builddir python3tmp
Name: python-%{modname}
Version: 1.10.0
Release: 1
Summary: Library with cross-python path, ini-parsing, io, code, log facilities
License: MIT and Public Domain
URL: http://pylib.readthedocs.io/en/stable/
Source0: https://files.pythonhosted.org/packages/0d/8c/50e9f3999419bb7d9639c37e83fa9cdcf0f601a9d407162d6c37ad60be71/py-1.10.0.tar.gz
BuildArch: noarch
%if %{with tests}
BuildRequires: subversion
%endif
%global _description \
The py lib is a Python development support library featuring the\
following tools and modules:\
\
* py.path: uniform local and svn path objects\
* py.apipkg: explicit API control and lazy-importing\
* py.iniconfig: easy parsing of .ini files\
* py.code: dynamic code generation and introspection
%description
%{_description}
%package -n python3-%{modname}
Summary: %{summary}
BuildRequires: python3-devel python3-setuptools python3-setuptools_scm
%if 0%{?with_help}
BuildRequires: %{_bindir}/sphinx-build-3
%endif
%if %{with tests}
BuildRequires: python3-pytest >= 2.9.0, python3-pytest < 2.10
%endif
Requires: python3-setuptools
%{?python_provide:%python_provide python3-%{modname}}
Provides: bundled(python3-apipkg) = 1.4 bundled(python3-iniconfig) = 1.0.0
Obsoletes: platform-python-%{modname} < %{version}-%{release}
%description -n python3-%{modname}
%{_description}
%if 0%{?with_help}
%package_help
%endif
%prep
%autosetup -c -n %{modnameversion}
find %{modnameversion} \
-type f -a \( -name '*.py' -o -name 'py.*' \) \
-exec sed -i '1{/^#!/d}' {} \; \
-exec chmod u=rw,go=r {} \;
mv %{modnameversion} %{p3builddir}
%build
pushd %{p3builddir}
%py3_build
%if 0%{?with_help}
make -C doc html PYTHONPATH=$(pwd) SPHINXBUILD=sphinx-build-3
%endif
popd
%install
pushd %{p3builddir}
%py3_install
rm -rf doc/_build/html/.buildinfo
popd
%check
%if %{with tests}
pushd %{p3builddir}
PYTHONPATH=%{buildroot}%{python3_sitelib} LC_ALL="en_US.UTF-8" \
py.test-%{python3_version} -r s -k"-TestWCSvnCommandPath" testing
popd
%endif
%files -n python3-%{modname}
%license %{p3builddir}/LICENSE
%{python3_sitelib}/py-*.egg-info/
%{python3_sitelib}/py/
%if 0%{?with_help}
%files help
%doc %{p3builddir}/CHANGELOG.rst
%doc %{p3builddir}/README.rst
%doc %{p3builddir}/doc/_build/html
%endif
%changelog
* Thu Jul 15 2021 OpenStack_SIG <[email protected]> - 1.10.0-1
- Update version to 1.10.0
* Mon Aug 10 2020 zhangjiapeng <[email protected]> - 1.5.4-5
- Remove python2
* Tue Dec 10 2019 mengxian <[email protected]> - 1.5.4-4
- Package init
Loading...
马建仓 AI 助手
尝试更多
代码解读
代码找茬
代码优化
1
https://gitee.com/src-oepkgs-oe-rv/python-py.git
[email protected]:src-oepkgs-oe-rv/python-py.git
src-oepkgs-oe-rv
python-py
python-py
master

搜索帮助