1 Star 0 Fork 45

rv_spare/redis

forked from src-openEuler/redis 
加入 Gitee
与超过 1200万 开发者一起发现、参与优秀开源项目,私有仓库也完全免费 :)
免费加入
文件
该仓库未声明开源许可证文件(LICENSE),使用请关注具体项目描述及其代码上游依赖。
克隆/下载
redis.spec 4.20 KB
一键复制 编辑 原始数据 按行查看 历史
Name: redis
Version: 4.0.11
Release: 12
Summary: A persistent key-value database
License: BSD and MIT
URL: https://redis.io
Source0: http://download.redis.io/releases/%{name}-%{version}.tar.gz
Source1: %{name}.logrotate
Source2: %{name}-sentinel.service
Source3: %{name}.service
#CVE fix
Patch0001: CVE-2019-10192-1.patch
#Optimization of the above problem
Patch0002: CVE-2019-10192-2.patch
Patch0003: CVE-2020-14147.patch
Patch0004: improved-HyperLogLog-cardinality-estimation.patch
Patch0005: Aesthetic-changes-to-PR.patch
Patch0006: CVE-2019-10193.patch
%ifarch aarch64
Patch0007: modify-aarch64-architecture-jemalloc-page-size-from-4k-to-64k.patch
%endif
Patch0008: huawei-deps-jemalloc-support-riscv.patch
BuildRequires: systemd
Requires: /bin/awk
Requires: logrotate
Requires(pre): shadow-utils
Requires(post): systemd
Requires(preun): systemd
Requires(postun): systemd
%description
Redis is an advanced key-value store. It is often referred to as a dattructure server since keys can contain strings, hashes
,lists, sets anorted sets.
%prep
%autosetup -p1
sed -i -e 's|^logfile .*$|logfile /var/log/redis/redis.log|g' redis.conf
sed -i -e '$ alogfile /var/log/redis/sentinel.log' sentinel.conf
sed -i -e 's|^dir .*$|dir /var/lib/redis|g' redis.conf
%build
make
%install
%make_install PREFIX=%{buildroot}%{_prefix}
install -d %{buildroot}%{_sharedstatedir}/%{name}
install -d %{buildroot}%{_localstatedir}/log/%{name}
install -d %{buildroot}%{_localstatedir}/run/%{name}
install -d %{buildroot}%{_libdir}/%{name}/modules
install -pDm644 %{SOURCE1} %{buildroot}%{_sysconfdir}/logrotate.d/%{name}
mkdir -p %{buildroot}%{_unitdir}
install -pm644 %{SOURCE2} %{buildroot}%{_unitdir}
install -pm644 %{SOURCE3} %{buildroot}%{_unitdir}
install -pDm640 %{name}.conf %{buildroot}%{_sysconfdir}/%{name}.conf
install -pDm640 sentinel.conf %{buildroot}%{_sysconfdir}/%{name}-sentinel.conf
%pre
getent group %{name} &> /dev/null || \
groupadd -r %{name} &> /dev/null
getent passwd %{name} &> /dev/null || \
useradd -r -g %{name} -d %{_sharedstatedir}/%{name} -s /sbin/nologin \
-c 'Redis Database Server' %{name} &> /dev/null
exit 0
%post
%systemd_post %{name}.service
%systemd_post %{name}-sentinel.service
%preun
%systemd_preun %{name}.service
%systemd_preun %{name}-sentinel.service
%postun
%systemd_postun_with_restart %{name}.service
%systemd_postun_with_restart %{name}-sentinel.service
%files
%license COPYING
%doc BUGS README.md 00-RELEASENOTES MANIFESTO CONTRIBUTING
%config(noreplace) %{_sysconfdir}/logrotate.d/%{name}
%attr(0640, redis, root) %config(noreplace) %{_sysconfdir}/%{name}.conf
%attr(0640, redis, root) %config(noreplace) %{_sysconfdir}/%{name}-sentinel.conf
%dir %attr(0750, redis, redis) %{_libdir}/%{name}
%dir %attr(0750, redis, redis) %{_libdir}/%{name}/modules
%dir %attr(0750, redis, redis) %{_sharedstatedir}/%{name}
%dir %attr(0750, redis, redis) %{_localstatedir}/log/%{name}
%{_bindir}/%{name}-*
%{_unitdir}/%{name}.service
%{_unitdir}/%{name}-sentinel.service
%changelog
* Wed Nov 11 2020 yangyanchao <[email protected]> - 4.0.11-12
- enable dependency package jemalloc of redis to support riscv
* Wed Sep 30 2020 Jiapeng Zhang <[email protected]> - 4.0.11-11
- Modify aarch64 architecture jemalloc page size from 4k to 64k
* Mon Sep 21 2020 wangyue <[email protected]> - 4.0.11-10
- fix CVE-2019-10193
* Mon Jul 20 2020 wangxiao <[email protected]> - 4.0.11-9
- fix CVE-2020-14147
* Fri Jun 19 2020 Captain Wei <[email protected]> - 4.0.11-8
- Add some dependency package in building and running phase
* Fri Jun 12 2020 panchenbo <[email protected]> - 4.0.11-7
- Type:bugfix
- ID: NA
- SUG: restart
- DESC: Resolve service startup failure whthout no %pre
* Mon Jun 01 2020 huanghaitao <[email protected]> - 4.0.11-6
- Resolve service startup failure
* Tue Mar 17 2020 wangye <[email protected]> - 4.0.11-5
- CVE name fix
* Tue Mar 17 2020 wangye <[email protected]> - 4.0.11-4
- CVE fix
* Wed Jan 15 2020 zhujunhao <[email protected]> - 4.0.11-3
- Modify redis service
* Wed Jan 08 2020 lijin Yang <[email protected]> - 4.0.11-2
- Package init
Loading...
马建仓 AI 助手
尝试更多
代码解读
代码找茬
代码优化
1
https://gitee.com/riscv-spare/redis.git
[email protected]:riscv-spare/redis.git
riscv-spare
redis
redis
master

搜索帮助