1 Star 0 Fork 14

niuzj0/node-gyp

forked from openEuler-RISC-V/node-gyp 
加入 Gitee
与超过 1200万 开发者一起发现、参与优秀开源项目,私有仓库也完全免费 :)
免费加入
文件
该仓库未声明开源许可证文件(LICENSE),使用请关注具体项目描述及其代码上游依赖。
克隆/下载
node-gyp.spec 2.51 KB
一键复制 编辑 原始数据 按行查看 历史
wangyangdahai 提交于 2022-03-16 19:58 . update test code for nodejs v16
%{?nodejs_find_provides_and_requires}
Name: node-gyp
Version: 3.6.0
Release: 5
Summary: Node.js native addon build tool
License: MIT
URL: https://github.com/nodejs/node-gyp
Source0: https://github.com/nodejs/node-gyp/archive/v%{version}/node-gyp-%{version}.tar.gz
Source1: addon-rpm.gypi
Patch1: node-gyp-addon-gypi.patch
Patch2: node-gyp-system-gyp.patch
Patch3: node-gyp-python.patch
Patch4: node-gyp-python3.patch
Patch5: node-gyp-update-test.patch
BuildArch: noarch
ExclusiveArch: %{nodejs_arches} noarch
Requires: gyp nodejs-devel libuv-devel http-parser-devel gcc-c++
BuildRequires: gyp nodejs-devel libuv-devel http-parser-devel gcc-c++
BuildRequires: npm(tape) npm(bindings) npm(fstream) npm(glob) npm(graceful-fs) npm(minimatch)
BuildRequires: npm(mkdirp) npm(nan) >= 2.0.0 npm(nopt) npm(npmlog) npm(osenv) npm(path-array)
BuildRequires: npm(request) npm(require-inject) npm(rimraf) npm(semver) npm(tar) npm(which) vim
%description
node-gyp is a cross-platform command-line tool written in Node.js for compiling
native addon modules for Node.js, which takes away the pain of dealing with the
various differences in build platforms. It is the replacement to the node-waf
program which is removed for node v0.8.
%prep
%autosetup -p1
cp -p %{SOURCE1} addon-rpm.gypi
%nodejs_fixdep glob "^6.0.4"
%nodejs_fixdep minimatch "^3.0.0"
rm -rf gyp
%build
%install
mkdir -p %{buildroot}%{nodejs_sitelib}/node-gyp
cp -pr addon*.gypi bin lib package.json %{buildroot}%{nodejs_sitelib}/node-gyp
mkdir -p %{buildroot}%{_bindir}
ln -sf ../lib/node_modules/node-gyp/bin/node-gyp.js %{buildroot}%{_bindir}/node-gyp
%nodejs_symlink_deps
%check
%{nodejs_symlink_deps} --check
%{nodejs_sitelib}/tape/bin/tape test/test-*.js
%files
%doc README.md CHANGELOG.md
%license LICENSE
%{nodejs_sitelib}/node-gyp
%{_bindir}/node-gyp
%changelog
* Tue Mar 16 2022 wangyangdahai <[email protected]> - 3.6.0-5
- update test code for nodejs v16
* Thu Jan 21 2021 lingsheng <[email protected]> - 3.6.0-4
- Limit npm(nan) version to fix test errors
* Tue Dec 29 2020 huanghaitao <[email protected]> - 3.6.0-3
- Fix test errors in node 12+
* Tue Sep 15 2020 chengzihan <[email protected]> - 3.6.0-2
- add patch node-gyp-python3.patch
- default to python3 instead of python2
* Mon Aug 17 2020 Shaoqiang Kang <[email protected]> - 3.6.0-1
- Package init
Loading...
马建仓 AI 助手
尝试更多
代码解读
代码找茬
代码优化
1
https://gitee.com/niuzj0/node-gyp.git
[email protected]:niuzj0/node-gyp.git
niuzj0
node-gyp
node-gyp
master

搜索帮助