1 Star 0 Fork 6

lingjuer/python-yubikey-manager

加入 Gitee
与超过 1200万 开发者一起发现、参与优秀开源项目,私有仓库也完全免费 :)
免费加入
文件
该仓库未声明开源许可证文件(LICENSE),使用请关注具体项目描述及其代码上游依赖。
克隆/下载
python-yubikey-manager.spec 2.98 KB
一键复制 编辑 原始数据 按行查看 历史
lingjuer 提交于 2023-08-03 09:36 . update version to 5.1.1
%global _empty_manifest_terminate_build 0
Name: python-yubikey-manager
Version: 5.1.1
Release: 1
Summary: Tool for managing your YubiKey configuration.
License: BSD
URL: https://github.com/Yubico/yubikey-manager
Source0: https://files.pythonhosted.org/packages/8e/70/d4c632df03f0c1f45ce26981a356fd10fe3ae49fccc1856769448efe396a/yubikey_manager-5.1.1.tar.gz
BuildArch: noarch
Requires: python3-dataclasses
Requires: python3-cryptography
Requires: python3-pyOpenSSL
Requires: python3-pyscard
Requires: python3-fido2
Requires: python3-click
Requires: python3-pywin32
Requires: python3-keyring
%description
Python library and command line tool for configuring a YubiKey. If you’re looking for the full graphical application, which also includes the command line tool,
%package -n python3-yubikey-manager
Summary: Tool for managing your YubiKey configuration.
Provides: python-yubikey-manager
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
BuildRequires: python3-wheel
BuildRequires: python3-poetry-core
%description -n python3-yubikey-manager
Python library and command line tool for configuring a YubiKey. If you’re looking for the full graphical application, which also includes the command line tool,
%package help
Summary: Development documents and examples for yubikey-manager
Provides: python3-yubikey-manager-doc
%description help
Python library and command line tool for configuring a YubiKey. If you’re looking for the full graphical application, which also includes the command line tool,
%prep
%autosetup -n yubikey_manager-%{version}
%build
%pyproject_build
%install
%pyproject_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
sed -i 's/\(^.*$\)/"\1"/g' filelist.lst doclist.lst
find %{buildroot} -type f -exec file {} ';' | grep "\<ELF\>" | awk -F ':' '{print $1}' | xargs -i chrpath --delete "{}"
%files -n python3-yubikey-manager -f filelist.lst
%dir %{python3_sitelib}/*
%{python3_sitelib}/ykman/*
%{python3_sitelib}/yubikit/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Thu Aug 03 2023 zhangchenglin <[email protected]> - 5.1.1-1
- Update package to version 5.1.1
* Tue Jan 25 2022 haomimi <[email protected]> - 4.0.7-1
- Package init
Loading...
马建仓 AI 助手
尝试更多
代码解读
代码找茬
代码优化
1
https://gitee.com/lingjuer/python-yubikey-manager.git
[email protected]:lingjuer/python-yubikey-manager.git
lingjuer
python-yubikey-manager
python-yubikey-manager
master

搜索帮助