代码拉取完成,页面将自动刷新
同步操作将从 src-openEuler/man-db 强制同步,此操作会覆盖自 Fork 仓库以来所做的任何修改,且无法恢复!!!
确定后同步将在后台操作,完成时将刷新页面,请耐心等待。
%global cache /var/cache/man
Name: man-db
Version: 2.9.3
Release: 3
Summary: Online database for using man pages
License: GPLv2+ and GPLv3+
URL: http://www.nongnu.org/man-db/
Source0: http://download.savannah.gnu.org/releases/%{name}/%{name}-%{version}.tar.xz
Source1: man-db.crondaily
Source2: man-db.sysconfig
Source3: man-db-cache-update.service
BuildRequires: gcc systemd gdbm-devel gettext groff less libpipeline-devel zlib-devel
BuildRequires: po4a perl-interpreter perl-version make
Requires: coreutils grep groff-base gzip less crontabs
Provides: man = %{version} man-pages-reader = %{version} bundled(gnulib) = 20140202
Obsoletes: man < 2.0
Provides: man-db-cron
Obsoletes: man-db-cron
%description
man-db is an implementation of the standard Unix documentation system accessed using the man command.
It uses a Berkeley DB database in place of the traditional flat-text whatis databases.
%prep
%autosetup -n %{name}-%{version}
%build
%configure \
--with-sections="1 1p 8 2 3 3p 4 5 6 7 9 0p n l p o 1x 2x 3x 4x 5x 6x 7x 8x" \
--disable-setuid --disable-cache-owner --with-browser=elinks --with-lzip=lzip
%make_build
%check
make check
%install
%make_install
# move the documentation to the relevant place
mv %{buildroot}%{_datadir}/doc/man-db/* ./
# install cache directory
install -d -m 0755 %{buildroot}/var/cache/man
# install cron script for man-db creation/update
mkdir -p %{buildroot}%{_sysconfdir}/cron.daily
install -D -p -m 0755 %{SOURCE1} %{buildroot}%{_sysconfdir}/cron.daily/man-db.cron
# config for cron script
mkdir -p %{buildroot}%{_sysconfdir}/sysconfig
install -D -p -m 0644 %{SOURCE2} %{buildroot}%{_sysconfdir}/sysconfig/man-db
# config for tmpfiles.d
install -D -p -m 0644 init/systemd/man-db.conf %{buildroot}/usr/lib/tmpfiles.d/.
# man-db-cache-update.service
install -D -p -m 0644 %{SOURCE3} %{buildroot}%{_unitdir}/man-db-cache-update.service
%find_lang %{name}
%find_lang %{name}-gnulib
%pre
%preun
%post
# clear the old cache
%{__rm} -rf %{cache}/* || :
# update cache
%transfiletriggerin -- %{_mandir}
if [ -x /usr/bin/systemd-run -a -x /usr/bin/systemctl ]; then
/usr/bin/systemd-run /usr/bin/systemctl start man-db-cache-update >/dev/null 2>&1 || :
fi
# update cache
%transfiletriggerpostun -- %{_mandir}
if [ -x /usr/bin/systemd-run -a -x /usr/bin/systemctl ]; then
/usr/bin/systemd-run /usr/bin/systemctl start man-db-cache-update >/dev/null 2>&1 || :
fi
%postun
%files -f %{name}.lang -f %{name}-gnulib.lang
%{!?_licensedir:%global license %%doc}
%license docs/COPYING
%doc README man-db-manual.txt man-db-manual.ps ChangeLog NEWS
%config(noreplace) %{_sysconfdir}/man_db.conf
%config(noreplace) %{_sysconfdir}/sysconfig/man-db
%config(noreplace) /usr/lib/tmpfiles.d/man-db.conf
%config(noreplace) %{_sysconfdir}/cron.daily/man-db.cron
%{_unitdir}/man-db-cache-update.service
%{_sbindir}/accessdb
%{_bindir}/man
%{_bindir}/whatis
%{_bindir}/apropos
%{_bindir}/manpath
%{_bindir}/lexgrog
%{_bindir}/catman
%{_bindir}/mandb
%{_bindir}/man-recode
%dir %{_libdir}/man-db
%{_libdir}/man-db/*.so
%dir %{_libexecdir}/man-db
%{_libexecdir}/man-db/globbing
%{_libexecdir}/man-db/manconv
%{_libexecdir}/man-db/zsoelim
/usr/lib/systemd/system/man-db.service
/usr/lib/systemd/system/man-db.timer
%verify(not mtime) %dir %{cache}
%lang(da) %{_datadir}/man/da/man*/*
%lang(de) %{_datadir}/man/de/man*/*
%lang(es) %{_datadir}/man/es/man*/*
%lang(fr) %{_datadir}/man/fr/man*/*
%lang(id) %{_datadir}/man/id/man*/*
%lang(it) %{_datadir}/man/it/man*/*
%lang(ja) %{_datadir}/man/ja/man*/*
%lang(nl) %{_datadir}/man/nl/man*/*
%lang(pl) %{_datadir}/man/pl/man*/*
%lang(pt_BR) %{_datadir}/man/pt_BR/man*/*
%lang(ru) %{_datadir}/man/ru/man*/*
%lang(sr) %{_datadir}/man/sr/man*/*
%lang(sv) %{_datadir}/man/sv/man*/*
%lang(tr) %{_datadir}/man/tr/man*/*
%lang(zh_CN) %{_datadir}/man/zh_CN/man*/*
%{_mandir}/man1/apropos.1*
%{_mandir}/man1/lexgrog.1*
%{_mandir}/man1/man.1*
%{_mandir}/man1/manconv.1*
%{_mandir}/man1/manpath.1*
%{_mandir}/man1/whatis.1*
%{_mandir}/man1/man-recode.1*
%{_mandir}/man5/manpath.5*
%{_mandir}/man8/accessdb.8*
%{_mandir}/man8/catman.8*
%{_mandir}/man8/mandb.8*
%{_mandir}/pt/man1/*
%{_mandir}/pt/man5/*
%{_mandir}/pt/man8/*
%exclude %{_datadir}/man/man1/zsoelim.1.gz
%exclude %{_libdir}/man-db/*.la
%changelog
* Tue Aug 17 2021 Jianmin <[email protected]> - 2.9.3-3
- Type:NA
- ID:NA
- SUG:NA
- DESC:change dependency on groff to groff-base
* Wed Nov 25 2020 shixuantong <[email protected]> - 2.9.3-2
- Type:NA
- ID:NA
- SUG:NA
- DESC:Delete unnecessary installation dependencies
* Thu Jul 16 2020 shixuantong <[email protected]> - 2.9.3-1
- Type:NA
- ID:NA
- SUG:NA
- DESC:update to 2.9.3-1
* Mon Feb 17 2020 chengquan <[email protected]> - 2.8.7-5
- Type:bugfix
- ID:NA
- SUG:NA
- DESC:Add necessary BuildRequire
* Mon Dec 16 2019 chengquan <[email protected]> - 2.8.7-4
- Type:bugfix
- ID:NA
- SUG:NA
- DESC:remove help package into main package
* Tue Sep 24 2019 chengquan <[email protected]> - 2.8.7-3
- Type:bugfix
- ID:NA
- SUG:NA
- DESC:revise requires of groff
* Fri Sep 20 2019 openEuler Buildteam <[email protected]> - 2.8.7-2
- Type:bugfix
- ID:NA
- SUG:NA
- DESC:fix error in POSTIN scriptlet
* Fri Sep 20 2019 openEuler Buildteam <[email protected]> - 2.8.7-1
- Type:bugfix
- ID:NA
- SUG:NA
- DESC:update software
* Thu Sep 19 2019 openEuler Buildteam <[email protected]> - 2.8.4-3
- Type:bugfix
- ID:NA
- SUG:NA
- DESC:add global marco
* Tue Sep 3 2019 openEuler Buildteam <[email protected]> - 2.8.4-2
- Package init
此处可能存在不合适展示的内容,页面不予展示。您可通过相关编辑功能自查并修改。
如您确认内容无涉及 不当用语 / 纯广告导流 / 暴力 / 低俗色情 / 侵权 / 盗版 / 虚假 / 无价值内容或违法国家有关法律法规的内容,可点击提交进行申诉,我们将尽快为您处理。