代码拉取完成,页面将自动刷新
同步操作将从 src-openEuler/parted 强制同步,此操作会覆盖自 Fork 仓库以来所做的任何修改,且无法恢复!!!
确定后同步将在后台操作,完成时将刷新页面,请耐心等待。
# This SPEC file come from GNU Parted Project(git://git.savannah.gnu.org/parted.git)
# Default to disabling device-mapper and SELinux
%define use_devmapper 0
%define use_selinux 0
%define use_sepol 0
# Enable device-mapper support if we find devmapper
%define use_devmapper %(pkg-config --libs devmapper >/dev/null 2>&1; [ $? -eq 0 ] && echo 1)
# Enable SELinux if we find libselinux and libsepol
%define use_selinux %([ -r %{_libdir}/libselinux.a ] && echo 1)
%define use_sepol %([ -r %{_libdir}/libsepol.so ] && echo 1)
Summary: The GNU disk partition manipulation program
Name: parted
Version: 3.3
Release: 1
URL: https://www.gnu.org/software/parted/
Source0: ftp://ftp.gnu.org/gnu/%{name}/%{name}-%{version}.tar.xz
License: GPLv3+
BuildRequires: e2fsprogs-devel e2fsprogs xfsprogs readline-devel ncurses-devel gettext-devel python3 gperf
BuildRequires: autoconf automake libtool gettext-devel texinfo pkgconfig gcc make bc dosfstools gnupg2 device-mapper-devel
BuildRequires: libblkid-devel >= 2.17
BuildRequires: device-mapper-devel, libselinux-devel libsepol-devel
Patch0000: 0000-Switch-gpt-header-move-and-msdos-overlap-to-python3.patch
Patch6000: 6000-add-support-of-gpt_sync_mbr.patch
Patch9000: 9000-Add-extra-judgment-for-a-partition-created-success.patch
Patch9001: 9001-bugfix-parted-fix-failure-of-mklabel-gpt_sync_mbr.patch
%description
The GNU Parted program allows you to create, destroy, resize, move,
and copy hard disk partitions. Parted can be used for creating space
for new operating systems, reorganizing disk usage, and copying data
to new hard disks.
%package devel
Summary: Files for developing apps which will manipulate disk partitions
Requires: %{name} = %{version}-%{release}
%description devel
The GNU Parted library is a set of routines for hard disk partition
manipulation. If you want to develop programs that manipulate disk
partitions and filesystems using the routines provided by the GNU
Parted library, you need to install this package.
%prep
%autosetup -n %{name}-%{version} -p1 -Sgit
%build
autoreconf
autoconf
%configure \
--enable-shared \
%if "%{use_devmapper}" == "1"
--enable-device-mapper \
%else
--disable-devmapper \
%endif
%if "%{use_selinux}" == "1" && "%{use_sepol}" == "1"
--enable-selinux \
%else
--disable-selinux \
%endif
--enable-part-static \
--enable-Werror=no \
--disable-dynamic-loading \
--disable-gcc-warnings
%{disable_rpath}
%{__make} %{?_smp_mflags}
%install
%{__rm} -rf %{buildroot}
%{__make} install DESTDIR=%{buildroot}
%{delete_la_and_a}
%{__rm} -rf %{buildroot}%{_infodir}/dir
%find_lang %{name}
%clean
%{__rm} -rf %{buildroot}
%check
export LD_LIBRARY_PATH=$(pwd)/libparted/.libs:$(pwd)/libparted/fs/.libs
make check
%post
if [ -f %{_infodir}/parted.info.gz ]; then
/sbin/install-info %{_infodir}/parted.info.gz %{_infodir}/dir || :
fi
%preun
if [ $1 = 0 ]; then
/sbin/install-info --delete %{_infodir}/parted.info.gz %{_infodir}/dir >/dev/null 2>&1 || :
fi
%postun -p /sbin/ldconfig
%files -f %{name}.lang
%license COPYING
%doc README doc/API doc/FAT
%{_sbindir}/parted
%{_sbindir}/partprobe
%{_libdir}/libparted*.so.*
%{_mandir}/man8/parted.8.gz
%{_mandir}/man8/partprobe.8.gz
%{_infodir}/parted.info.gz
%files devel
%{_includedir}/parted
%{_libdir}/libparted*.so
%{_libdir}/pkgconfig/libparted*.pc
%changelog
* Wed Feb 19 2020 hy-euler <[email protected]> - 3.3-1
- Type:enhancement
- ID:NA
- SUG:NA
- DESC:Add check part and enable pc98 in spec file
* Sat Jan 11 2020 openEuler Buildteam <[email protected]> - 3.3-0
- Type:enhancement
- ID:NA
- SUG:NA
- DESC:update package from 3.2 to 3.3
* Tue Dec 31 2019 openEuler Buildteam <[email protected]> - 3.2-39
- Type:enhancement
- ID:NA
- SUG:NA
- DESC:delete unused file
* Sat Sep 21 2019 suweifeng <[email protected]> - 3.2-38
- Type:enhancement
- ID:NA
- SUG:NA
- DESC:License update
* Mon Sep 09 2019 suweifeng <[email protected]> - 3.2-37
- Type:enhancement
- ID:NA
- SUG:NA
- DESC:openEuler Debranding
* Tue Aug 20 2019 luoshijie<[email protected]> - 3.2-36.h5
- Type:bugfix
- ID:NA
- SUG:restart
- DESC:change name of patch.
* Wed May 8 2019 louhongxiang<[email protected]> - 3.2-36.h4
- Type:bugfix
- ID:NA
- SUG:restart
- DESC:change name of patch.
* Thu Mar 21 2019 louhongxiang<[email protected]> - 3.2-36.h3
- Type:bugfix
- ID:NA
- SUG:restart
- DESC:add support for gpt_sync_mbr and fix failure of it.
* Wed Mar 20 2019 yanghua<[email protected]> - 3.2-36.h2
- Type:bugfix
- ID:NA
- SUG:restart
- DESC:parted fix crash due to improper partition number in
parted fix wrong error label jump in mkpart
clean the disk information when commands fail in int
libparted Fix ending CHS address in PMBR
Fix the length of several strncpy calls
parted.c Always free peek_word
parted.c Make sure dev_name is freed
Fix potential command line buffer overflow
* Fri Jan 25 2019 Xiaoqi Guo<[email protected]> - 3.2-36.h1
- Type:new-packages
- ID:NA
- SUG:NA
- DESC:add patches, include
huawei-bugfix-Add-extra-judgment-for-a-partition-created-success.patch
huawei-bugfix-add-support-of-gpt_sync_mbr.patch
* Tue Mar 13 2007 David Cantrell <[email protected]>
- Updated spec file
* Mon Mar 13 2000 Fabian Emmes <[email protected]>
- changed "unset LINGUAS" line
- reintroduced %build section ;)
- started changelog
此处可能存在不合适展示的内容,页面不予展示。您可通过相关编辑功能自查并修改。
如您确认内容无涉及 不当用语 / 纯广告导流 / 暴力 / 低俗色情 / 侵权 / 盗版 / 虚假 / 无价值内容或违法国家有关法律法规的内容,可点击提交进行申诉,我们将尽快为您处理。