1 Star 0 Fork 15

dongQ/python-cocotb

加入 Gitee
与超过 1200万 开发者一起发现、参与优秀开源项目,私有仓库也完全免费 :)
免费加入
文件
该仓库未声明开源许可证文件(LICENSE),使用请关注具体项目描述及其代码上游依赖。
克隆/下载
python-cocotb.spec 2.95 KB
一键复制 编辑 原始数据 按行查看 历史
dongQ 提交于 2024-10-29 09:38 . Update to 1.9.1
%global _empty_manifest_terminate_build 0
Name: python-cocotb
Version: 1.9.1
Release: 1
Summary: cocotb is a coroutine based cosimulation library for writing VHDL and Verilog testbenches in Python.
License: BSD
URL: https://docs.cocotb.org
Source0: https://files.pythonhosted.org/packages/d6/bc/896a0c04656e02b9abe8f0b6e97c8f54af0d00e83a5fcb8ee03edff06d90/cocotb-1.9.1.tar.gz
BuildRequires: python3-devel
BuildRequires: python3dist(setuptools)
BuildRequires: python3dist(setuptools-scm)
BuildRequires: python3dist(pytest)
BuildRequires: gcc, gcc-c++, make
BuildRequires: libstdc++-static
ExcludeArch: s390x
%description
cocotb is a coroutine based cosimulation library for writing VHDL and Verilog testbenches in Python.
%package -n python3-cocotb
Summary: cocotb is a coroutine based cosimulation library for writing VHDL and Verilog testbenches in Python.
Provides: python-cocotb
BuildRequires: python3-devel
BuildRequires: python3-setuptools
%description -n python3-cocotb
cocotb is a coroutine based cosimulation library for writing VHDL and Verilog testbenches in Python.
%package help
Summary: Development documents and examples for cocotb
Provides: python3-cocotb-doc
%description help
cocotb is a coroutine based cosimulation library for writing VHDL and Verilog testbenches in Python.
%prep
%autosetup -n cocotb-%{version}
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-cocotb -f filelist.lst
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Oct 29 2024 dongqi <[email protected]> - 1.9.1-1
- Update package to version 1.9.1
- Support setuptools 72.2.0
* Sat Aug 03 2024 muxiaohui <[email protected]> - 1.9.0-1
- Update package to version 1.9.0
- cocotb 1.9 improves simulator support and prepares for the next major release
* Fri Jul 12 2024 Hann <[email protected]> - 1.8.1-1
- Update package to version 1.8.1-1
- Fixed a segmentation fault in Aldec Riviera-PRO that prevented mixed-language simulation from running
- Fixed the packaging of the source distribution (sdist) to include all necessary files
* Wed Jul 13 2022 wanglianguo <[email protected]> - 1.6.2-1
- Package Spec generated
Loading...
马建仓 AI 助手
尝试更多
代码解读
代码找茬
代码优化
1
https://gitee.com/dongqi1111/python-cocotb.git
[email protected]:dongqi1111/python-cocotb.git
dongqi1111
python-cocotb
python-cocotb
master

搜索帮助