1 Star 0 Fork 16

baijing_0022/zsh

forked from src-openEuler/zsh 
加入 Gitee
与超过 1200万 开发者一起发现、参与优秀开源项目,私有仓库也完全免费 :)
免费加入
文件
该仓库未声明开源许可证文件(LICENSE),使用请关注具体项目描述及其代码上游依赖。
克隆/下载
zsh.spec 5.34 KB
一键复制 编辑 原始数据 按行查看 历史
陈棋德 提交于 2022-10-09 15:39 . update to 5.9
%define _bindir /bin
Name: zsh
Version: 5.9
Release: 1
Summary: A shell designed for interactive use
License: MIT
URL: http://zsh.sourceforge.net
Source0: https://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.xz
# There are five startup files that zsh will read commands from
# http://zsh.sourceforge.net/Intro/intro_3.html
Source1: zlogin
Source2: zlogout
Source3: zprofile
Source4: zshrc
Source5: zshenv
Source6: dotzshrc
BuildRequires: autoconf coreutils gawk gdbm-devel libcap-devel make
BuildRequires: ncurses-devel pcre-devel sed texinfo hostname gcc
Requires(post): info grep
Requires(preun): info
Requires(postun): coreutils grep
Provides: /bin/zsh
%description
The zsh is a shell designed for interactive use, and it is also a powerful scripting language. Many of
the useful features of bash, ksh, and tcsh were incorporated into zsh. It can match files by file extension
without running an external program, share command history with any shell, and more.
%package help
Summary: zsh shell manual in html format
BuildArch: noarch
Provides: zsh-html
Obsoletes: zsh-html
%description help
This package contains the zsh manual in html format.
%prep
%autosetup -p1
autoreconf -fiv
sed -e 's|^\.NOTPARALLEL|#.NOTPARALLEL|' -i 'Config/defs.mk.in'
%build
%undefine _strict_symbol_defs_build
export LIBLDFLAGS='-z lazy -fstack-protector-strong'
%configure --enable-etcdir=%{_sysconfdir} --with-tcsetpgrp --enable-maildir-support --enable-pcre
make -C Src headers
make -C Src -f Makemod zsh{path,xmod}s.h version.h
%make_build all html
%check
make check
%install
%make_install install.info fndir=%{_datadir}/%{name}/%{version}/functions sitefndir=%{_datadir}/%{name}/site-functions \
scriptdir=%{_datadir}/%{name}/%{version}/scripts sitescriptdir=%{_datadir}/%{name}/scripts \
runhelpdir=%{_datadir}/%{name}/%{version}/help
rm -f $RPM_BUILD_ROOT%{_bindir}/zsh-%{version}
rm -f $RPM_BUILD_ROOT%{_infodir}/dir
install -d ${RPM_BUILD_ROOT}%{_sysconfdir}
for i in %{SOURCE1} %{SOURCE2} %{SOURCE3} %{SOURCE4} %{SOURCE5}; do
install -m 644 $i $RPM_BUILD_ROOT%{_sysconfdir}/"${i##*/}"
done
install -d $RPM_BUILD_ROOT%{_sysconfdir}/skel
install -m 644 %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}/skel/.zshrc
for i in checkmail harden run-help zcalc zkbd; do
sed -i -e 's!/usr/local/bin/zsh!%{_bindir}/zsh!' $RPM_BUILD_ROOT%{_datadir}/zsh/%{version}/functions/$i
chmod +x $RPM_BUILD_ROOT%{_datadir}/zsh/%{version}/functions/$i
done
%post
if [ "$1" = 1 ]; then
if [ ! -f %{_sysconfdir}/shells ] ; then
echo "%{_bindir}/%{name}" > %{_sysconfdir}/shells
echo "/bin/%{name}" >> %{_sysconfdir}/shells
else
grep -q "^%{_bindir}/%{name}$" %{_sysconfdir}/shells || echo "%{_bindir}/%{name}" >> %{_sysconfdir}/shells
grep -q "^/bin/%{name}$" %{_sysconfdir}/shells || echo "/bin/%{name}" >> %{_sysconfdir}/shells
fi
fi
if [ -f %{_infodir}/zsh.info.gz ]; then
/sbin/install-info %{_infodir}/zsh.info.gz %{_infodir}/dir \
--entry="* zsh: (zsh). An enhanced bourne shell."
fi
%preun
if [ "$1" = 0 ] ; then
if [ -f %{_infodir}/zsh.info.gz ]; then
/sbin/install-info --delete %{_infodir}/zsh.info.gz %{_infodir}/dir \
--entry="* zsh: (zsh). An enhanced bourne shell."
fi
fi
%postun
if [ "$1" = 0 ] && [ -f %{_sysconfdir}/shells ] ; then
sed -i '\!^%{_bindir}/%{name}$!d' %{_sysconfdir}/shells
sed -i '\!^/bin/%{name}$!d' %{_sysconfdir}/shells
fi
%files
%doc README LICENCE Etc/* FEATURES MACHINES NEWS
%attr(755,root,root) %{_bindir}/zsh
%{_libdir}/zsh
%config(noreplace) %{_sysconfdir}/skel/.z*
%config(noreplace) %{_sysconfdir}/z*
%{_datadir}/zsh
%files help
%doc Doc/*.html
%{_mandir}/*/*
%{_infodir}/*
%changelog
* Sun Oct 9 2022 dillon chen < [email protected]> - 5.9-1
- update to 5.9
* Tue Mar 1 2022 wangjie <[email protected]> - 5.8-3
- Type: CVE
- ID: CVE-2021-45444
- SUG: NA
- DESC: fix CVE-2021-45444
* Sat Mar 20 2021 shenyangyang <[email protected]> - 5.8-2
- Type:enhancement
- ID:NA
- SUG:NA
- DESC:add -fstack-protector-strong for so file
* Fri Jan 29 2021 zoulin <[email protected]> - 5.8-1
- Type:enhancement
- ID:NA
- SUG:NA
- DESC:update version to 5.8
* Wed Jun 24 2020 xuping <[email protected]> - 5.7.1-5
- Type:cves
- ID:CVE-2019-20044
- SUG:NA
- DESC:fix CVE-2019-20044
* Thu Feb 6 2020 openEuler Buildteam <[email protected]> - 5.7.1-4
- Type:enhancement
- ID:NA
- SUG:NA
- DESC:add buildrequires of gcc and make
* Mon Feb 3 2020 openEuler Buildteam <[email protected]> - 5.7.1-3
- Type:enhancement
- ID:NA
- SUG:NA
- DESC:fix missing files
* Wed Jan 15 2020 openEuler Buildteam <[email protected]> - 5.7.1-2
- Type:enhancement
- ID:NA
- SUG:NA
- DESC:revise buildrequires
* Wed Jan 8 2020 openEuler Buildteam <[email protected]> - 5.7.1-1
- Type:enhancement
- ID:NA
- SUG:NA
- DESC:update version to 5.7.1
* Wed Dec 18 2019 jiangchuangang <[email protected]> - 5.6.2-3
- Type:enhancement
- ID:NA
- SUG:restart
- DESC:Synchronize a patch
* Wed Sep 18 2019 dongjian <[email protected]> - 5.6.2-2
- modify summary
Loading...
马建仓 AI 助手
尝试更多
代码解读
代码找茬
代码优化
1
https://gitee.com/baijing_0022/zsh.git
[email protected]:baijing_0022/zsh.git
baijing_0022
zsh
zsh
master

搜索帮助