5 Star 0 Fork 0

OpenCloudOS Stream/percolator

加入 Gitee
与超过 1200万 开发者一起发现、参与优秀开源项目,私有仓库也完全免费 :)
免费加入
文件
该仓库未声明开源许可证文件(LICENSE),使用请关注具体项目描述及其代码上游依赖。
克隆/下载
percolator.spec 6.71 KB
一键复制 编辑 原始数据 按行查看 历史
fanjunkong 提交于 2024-09-05 10:32 . Delete irrelevant keywords
%undefine _ld_as_needed
%global __cmake_in_source_build 1
Name: percolator
Summary: Software for postprocessing of shotgun proteomics data
Version: 3.06.01
Release: 1%{?dist}.1
License: ASL 2.0 and MIT and BSD and LGPLv2+
URL: https://github.com/percolator/percolator
Source0: https://github.com/percolator/percolator/archive/rel-3-06-01/percolator-rel-3-06-01.tar.gz
Source1: http://noble.gs.washington.edu/proj/percolator/data/yeast-01.sqt.tar.gz
Source2: %{name}-RAMP_license_lgpl-2.1.txt
BuildRequires: make
BuildRequires: gcc, gcc-c++
BuildRequires: cmake
BuildRequires: gtest-devel
BuildRequires: python3-devel
BuildRequires: boost-static, boost-devel
BuildRequires: pkgconfig(tokyocabinet)
BuildRequires: pkgconfig(xerces-c)
BuildRequires: pkgconfig(sqlite3)
BuildRequires: pkgconfig(libtirpc)
BuildRequires: xsd, zlib-devel, bzip2-devel
Requires: %{name}-data = %{version}-%{release}
%description
The first step in analyzing an mass spectrometry assay is to match
the harvested spectra against a target database
using database search engines such as Sequest and Mascot,
a process that renders list of peptide-spectrum matches.
However, it is not trivial to assess the accuracy
of these identifications.
Percolator uses a semi-supervised machine learning to
discriminate correct from incorrect peptide-spectrum matches,
and calculates accurate statistics such as q-value (FDR)
and posterior error probabilities.
%package data
Summary: percolator data files
BuildArch: noarch
Requires: xml-common
%description data
This package contains XSD data files of %{name} and
models of elude tool.
%package static
Summary: percolator static libraries
%description static
This package contains static libraries of %{name}.
%prep
%autosetup -n percolator-rel-3-06-01
tar -xvf %{SOURCE1}
find . -type f -name "*.cpp" -exec chmod 0644 '{}' \;
find . -type f -name "*.h" -exec chmod 0644 '{}' \;
find . -type f -name "*.xx" -exec chmod 0644 '{}' \;
find . -type f -name "*.txt" -exec chmod 0644 '{}' \;
chmod a-x src/converters/MSToolkit/RAMP/README
mv src/converters/MSToolkit/RAMP/README src/converters/MSToolkit/RAMP/RAMP-README
mv src/converters/MSToolkit/RAMP/Readme.Mike.txt src/converters/MSToolkit/RAMP/RAMP-Readme.Mike.txt
cp -p %{SOURCE2} RAMP_license_lgpl-2.1.txt
sed -e 's|./bin|bin|g' -i src/qvality/CMakeLists.txt
%build
export CXXFLAGS="-std=c++14 $RPM_OPT_FLAGS"
mkdir -p percolator && pushd percolator
%cmake -Wno-dev \
-DCMAKE_COLOR_MAKEFILE:BOOL=ON \
-DCMAKE_VERBOSE_MAKEFILE=TRUE -DXML_SUPPORT:BOOL=ON \
-DCMAKE_CXX_FLAGS_RELEASE:STRING="%{optflags} -I../src -I%{_includedir}/xsd/cxx/tree -I%{_includedir}/tirpc" \
-DCMAKE_EXE_LINKER_FLAGS_RELEASE:STRING="%{__global_ldflags} -ltirpc" \
-DCMAKE_BUILD_TYPE:STRING=Release \
-DCMAKE_SKIP_INSTALL_RPATH:BOOL=YES -DCMAKE_SKIP_RPATH:BOOL=YES \
-DTARGET_ARCH=%{_arch} ..
cd src
xsdcxx cxx-tree --generate-insertion XDR --generate-extraction XDR --root-element-all \
--namespace-map http://per-colator.com/percolator_in/13=percolatorInNs ../../src/xml/percolator_in.xsd
xsdcxx cxx-tree --generate-serialization --generate-insertion XDR --generate-extraction XDR --root-element-all \
--namespace-map http://per-colator.com/percolator_out/15=percolatorOutNs ../../src/xml/percolator_out.xsd
cd ..
%make_build
popd
mkdir -p fido && pushd fido
%cmake -Wno-dev \
-DCMAKE_COLOR_MAKEFILE:BOOL=ON \
-DCMAKE_VERBOSE_MAKEFILE=TRUE \
-DCMAKE_BUILD_TYPE:STRING=Release \
-DTokyoCabinet_INCLUDE_DIR=%{_includedir} \
-DTokyoCabinet_LIBRARY=%{_libdir}/libtokyocabinet.so \
-DCMAKE_CXX_FLAGS_RELEASE:STRING="%{optflags} -I../src -I%{_includedir}/xsd/cxx/tree -I%{_includedir}/tirpc" \
-DCMAKE_EXE_LINKER_FLAGS_RELEASE:STRING="%{__global_ldflags} -ltirpc" \
-DCMAKE_SKIP_INSTALL_RPATH:BOOL=YES -DCMAKE_SKIP_RPATH:BOOL=YES \
-DTARGET_ARCH=%{_arch} ../src/fido
%make_build
popd
mkdir -p converters && pushd converters
%cmake -Wno-dev \
-DCMAKE_COLOR_MAKEFILE:BOOL=ON \
-DCMAKE_VERBOSE_MAKEFILE=TRUE \
-DCMAKE_CXX_FLAGS_RELEASE:STRING="%{optflags} -I../src -I%{_includedir}/xsd/cxx/tree -I%{_includedir}/tirpc" \
-DCMAKE_EXE_LINKER_FLAGS_RELEASE:STRING="%{__global_ldflags} -ltirpc" \
-DCMAKE_BUILD_TYPE:STRING=Release \
-DPERCOLATOR-CONVERTERS_BINARY_DIR:STATIC=converters \
-DCMAKE_SKIP_INSTALL_RPATH:BOOL=YES -DCMAKE_SKIP_RPATH:BOOL=YES \
-DTokyoCabinet_INCLUDE_DIR=%{_includedir} \
-DTokyoCabinet_LIBRARY=%{_libdir}/libtokyocabinet.so \
-DSERIALIZE="TokyoCabinet" \
-DTARGET_ARCH=%{_arch} ../src/converters
xsdcxx cxx-tree --generate-serialization --generate-insertion XDR --generate-extraction XDR --root-element-all \
--namespace-map http://per-colator.com/percolator_in/13=percolatorInNs ../src/xml/percolator_in.xsd
xsdcxx cxx-tree --generate-serialization --generate-insertion XDR --generate-extraction XDR --root-element-all \
--namespace-map http://per-colator.com/percolator_out/15=percolatorOutNs ../src/xml/percolator_out.xsd
xsdcxx cxx-tree --generate-serialization --generate-insertion XDR --generate-extraction XDR --root-element-all \
--namespace-map http://psidev.info/psi/pi/mzIdentML/1.1=mzIdentML_ns ../src/xml/mzIdentML1.1.0.xsd
xsdcxx cxx-tree --generate-serialization --generate-insertion XDR --generate-extraction XDR --root-element-all \
--namespace-map http://www.bioml.com/gaml/=gaml_tandem_ns ../src/xml/gaml_tandem1.0.xsd
xsdcxx cxx-tree --generate-serialization --generate-insertion XDR --generate-extraction XDR --root-element-all \
--namespace-map http://www.thegpm.org/TANDEM/2011.12.01.1=tandem_ns --namespace-map =tandem_ns \
--namespace-map http://www.bioml.com/gaml/=gaml_tandem_ns ../src/xml/tandem2011.12.01.1.xsd
%make_build
popd
%install
%make_install -C percolator
%make_install -C converters
mkdir -p %{buildroot}%{_libdir}/percolator
for i in `find . -type f \( -name "*.a" \)`; do
install -pm 755 $i %{buildroot}%{_libdir}/percolator
done
rm -f %{buildroot}%{_bindir}/gtest_unit
%check
mkdir -p test && pushd test
../converters/sqt2pin -o pin.tab ../yeast-01.sqt ../yeast-01.shuffled.sqt
../percolator/src/percolator -X pout.xml pin.tab > yeast-01.psms
popd
pushd percolator
%ifarch %{ix86}
%else
%ctest
%endif
popd
%files
%{_bindir}/percolator
%{_bindir}/sqt2pin
%{_bindir}/qvality
%{_bindir}/tandem2pin
%{_bindir}/msgf2pin
%files data
%doc ReadMe.txt
%doc src/converters/MSToolkit/RAMP/RAMP-*
%license license.txt
%license RAMP_license_lgpl-2.1.txt
%{_datadir}/percolator/
%{_datadir}/xml/percolator/
%files static
%doc ReadMe.txt
%doc src/converters/MSToolkit/RAMP/RAMP-*
%license license.txt
%license RAMP_license_lgpl-2.1.txt
%{_libdir}/percolator/
%changelog
* Thu Sep 05 2024 OpenCloudOS Release Engineering <[email protected]> - 3.06.01-1.2
- delete irrelevant keywords
* Fri Apr 12 2024 OpenCloudOS Release Engineering <[email protected]> - 3.06.01-1
- initial build
Loading...
马建仓 AI 助手
尝试更多
代码解读
代码找茬
代码优化
1
https://gitee.com/opencloudos-stream/percolator.git
[email protected]:opencloudos-stream/percolator.git
opencloudos-stream
percolator
percolator
master

搜索帮助