1 Star 0 Fork 4

edwardewang/qt5-qtsensors

加入 Gitee
与超过 1200万 开发者一起发现、参与优秀开源项目,私有仓库也完全免费 :)
免费加入
文件
该仓库未声明开源许可证文件(LICENSE),使用请关注具体项目描述及其代码上游依赖。
克隆/下载
qt5-qtsensors.spec 2.65 KB
一键复制 编辑 原始数据 按行查看 历史
edwardewang 提交于 2024-01-18 14:46 . Upgrade to 5.15.11
%global qt_module qtsensors
%global majmin %%(echo %{version} | cut -d. -f1-2)
%global __provides_exclude_from ^(%{_qt5_archdatadir}/qml/.*\\.so|%{_qt5_plugindir}/.*\\.so)$
Summary: Qt5 - Sensors component
Name: qt5-%{qt_module}
Version: 5.15.11
Release: 1%{?dist}
License: LGPLv2 with exceptions or GPLv3 with exceptions
Url: http://www.qt.io/
Source0: https://download.qt.io/official_releases/qt/%{majmin}/%{version}/submodules/%{qt_module}-everywhere-opensource-src-%{version}.tar.xz
BuildRequires: make qt5-qtbase-devel qt5-qtbase-private-devel qt5-qtdeclarative-devel
%{?_qt5:Requires: %{_qt5} = %{_qt5_version}}
Recommends: iio-sensor-proxy
%description
The Qt Sensors API provides access to sensor hardware via QML and C++ interfaces. The Qt Sensors
API also provides a motion gesture recognition API for devices.
%package devel
Summary: Development files for %{name}
Requires: %{name} = %{version}-%{release} qt5-qtbase-devel
Provides: %{name}-examples = %{version}-%{release}
%description devel
Qt5 - Sensors component.
%prep
%autosetup -n %{qt_module}-everywhere-src-%{version}
%build
%{qmake_qt5}
%make_build
%install
make install INSTALL_ROOT=%{buildroot}
pushd %{buildroot}%{_qt5_libdir}
for prl_file in libQt5*.prl ; do
sed -i -e "/^QMAKE_PRL_BUILD_DIR/d" ${prl_file}
if [ -f "$(basename ${prl_file} .prl).so" ]; then
rm -fv "$(basename ${prl_file} .prl).la"
sed -i -e "/^QMAKE_PRL_LIBS/d" ${prl_file}
fi
done
popd
%files
%license LICENSE.*
%{_qt5_libdir}/libQt5Sensors.so.5*
%{_qt5_plugindir}/sensorgestures/
%{_qt5_plugindir}/sensors/
%{_qt5_archdatadir}/qml/QtSensors/
%dir %{_qt5_libdir}/cmake/Qt5Sensors/
%{_qt5_libdir}/cmake/Qt5Sensors/Qt5Sensors_*Plugin.cmake
%files devel
%{_qt5_headerdir}/QtSensors/
%{_qt5_libdir}/libQt5Sensors.so
%{_qt5_libdir}/libQt5Sensors.prl
%{_qt5_libdir}/cmake/Qt5Sensors/Qt5SensorsConfig*.cmake
%{_qt5_libdir}/pkgconfig/Qt5Sensors.pc
%{_qt5_archdatadir}/mkspecs/modules/qt_lib_sensors*.pri
%{_qt5_examplesdir}/
%changelog
* Wed Jan 17 2024 edwardewang <[email protected]> - 5.15.11-1
- Upgrade to 5.15.11
* Thu Sep 21 2023 kianli <[email protected]> - 5.15.10-1
- Upgrade to 5.15.10
* Fri Sep 08 2023 OpenCloudOS Release Engineering <[email protected]> - 5.15.9-2
- Rebuilt for OpenCloudOS Stream 23.09
* Fri Jul 14 2023 Shuo Wang <[email protected]> - 5.15.9-1
- update to 5.15.9
* Fri Apr 28 2023 OpenCloudOS Release Engineering <[email protected]> - 5.15.7-3
- Rebuilt for OpenCloudOS Stream 23.05
* Fri Mar 31 2023 OpenCloudOS Release Engineering <[email protected]> - 5.15.7-2
- Rebuilt for OpenCloudOS Stream 23
* Fri Mar 17 2023 Shuo Wang <[email protected]> - 5.15.7-1
- initial build
Loading...
马建仓 AI 助手
尝试更多
代码解读
代码找茬
代码优化
1
https://gitee.com/EdwardElric233/qt5-qtsensors.git
[email protected]:EdwardElric233/qt5-qtsensors.git
EdwardElric233
qt5-qtsensors
qt5-qtsensors
master

搜索帮助